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ArcGIS Metadata for ArcGIS Online, FGDC Style, from Scratch 

Version 1.7 

This document is intended to provide guidance for data and metadata providers to the 

State of New Jersey ArcGIS Online / Open Data site and to partner sites. As of Spring 2018, 

this site is set to use FGDC style ArcGIS metadata. 

https://njgin.state.nj.us/oit/gis/NJ_NJGINExplorer/docs/MD_ArcGIS_from_scratch_for_AGO.pdf 
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Summary 

 Set up tools: Configure ArcCatalog 

 Gather information about the data 

 Synchronize metadata with data 

 Edit the metadata to add information needed for the intended purpose 

 Thumbnail, easy or custom 

 Create file for AGOL 

  

https://njgin.state.nj.us/oit/gis/NJ_NJGINExplorer/docs/MD_ArcGIS_from_scratch_for_AGO.pdf
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Things to Remember 

 If starting with existing metadata in FGDC CSDGM format, instead of this 

document, please refer to Transitioning from FGDC to ArcGIS metadata, 

FGDC style for ArcGIS Online. There are several very important differences in 

workflow. That document also explains how to generate new FGDC CSDGM 

xml files from ArcGIS metadata.  

 Date formatting: for a date in a free text field, enter in this format:  

2018-02-15.  

 Change Publication Date for re-release of updated data. 

 Need to transfer metadata contents with no changes? Use the ArcToolbox 

Metadata Importer tool (Conversion tools -> Metadata -> Metadata Importer). 

Do not use the Export or Import buttons on the Description tab, nor the 

Export Metadata model. When using the tool, the Source is the file with good 

metadata. The Target metadata will be replaced in full. 

 For submissions of metadata to ArcGIS Online, a cleaned-up record is 

important. See Section I, Producing Metadata for ArcGIS Online. 

Step by Step Instructions 

A. Essential tools - set up in preparation 

1. These instructions are written for ArcGIS 10.3.1 for Desktop. In previous 

versions the ArcGIS editor does not work as well. There are no major changes to 

metadata editing in ArcGIS 10.5.1. ArcGIS Pro still lacks the full metadata 

functionality in ArcCatalog. Check back in early 2019 for update. 

 

2. Remember that whatever object is highlighted in the Catalog Tree will be active, 

and visible in Contents and Preview. Its metadata will be visible in Description 

tab, and will be opened for editing if you click the Edit button there.  

 

3. Set up ArcCatalog properly for FGDC style metadata. Customize menu -> 

Options -> Metadata tab. Set up as shown, including unchecking automatic 

updates, and prompts:  (see below) 
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4. Optional: Install Notepad++, including the XML Tools plugin. This is free 

software under the GNU General Public License as published by the Free Software 

Foundation. 

 

5. Optional: Install XML Notepad. This is a free download form Lovett Software. 

Set it to save files WITHOUT initial Byte Order Mark. (View -> Options -> 

Formatting Options -> No byte order mark on save = True) 

 

The above two tools are useful if for editing an xml file directly, outside of a 

structured metadata editor. Not all metadata writers need to do this. 

 

6. Obtain tools that help when editing FGDC metadata, such as the Metadata Quick 

Guide and perhaps the FGDC CSDGM Workbook. 

 

7. ArcGIS Desktop Help for using the new editor to produce FGDC CSDGM style 

metadata: There are various useful help topics under Geodata -> Data types -> 

Metadata. The one you are most likely to need repeatedly is Illustrated guide to 

complete FGDC metadata, under Editing metadata -> Metadata workflows. You 

might want to “Favorite” that one. 
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B. Gather information about the data set 

1. If the data have not been created yet: Set up a way to collect notes or a formal 

project log, depending on how large and complicated the process will be. Twenty 

Questions about Geospatial Data, available from NJGIN as a PDF file and as an MS 

Word file, may be of help. 

 

2. If you created the data: Review notes or project log. If you wrote any FGDC 

CSDGM metadata, instead of this document consult Transitioning from FGDC to 

ArcGIS metadata, FGDC style for ArcGIS Online, also available from NJGIN. 

 

3. If someone else created the data: Request notes and/or an interview. If you are 

not sure what to ask, try using Twenty Questions about Geospatial Data (see 

above.) Also, double-check to see if the data have FGDC CSDGM metadata 

attached already. If so, extensive information will be visible at the very bottom 

of the ArcCatalog Description tab in a grey font; expand the section entitled 

FGDC Metadata (read only). If extensive FGDC CSDGM metadata are present, see 

2. above. 

 

4. If Esri tools were used to create the data: Review any geoprocessing 

information that was captured automatically and is visible on the ArcCatalog 

Description tab. If there is extensive information there, back it up by creating a 

blank xml (see screen shot below) and using the Metadata Importer tool (see 

Things to Remember, above for tool help.) 

C. Template  If several data sets from the same organization need metadata, it is 

useful to create a generic record (xml) that includes the information that will be the 

same for all of them, such as the Metadata Contact, the Originator, the Publisher, 

Access and Use Constraints, Distribution Liability, etc.  

1. Create a blank xml in ArcCatalog, using the context menu:
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2. Highlight the new blank xml and name it Template.xml or some variation. 

3. Use the ArcGIS metadata editor, start editing, and write the appropriate 

information into the Template xml, then Save. (See section F. below for editing 

instructions.)  

4. Use the Import button on the Description tab to import the template into 

association with a data set that needs metadata. The Source Metadata is your 

personalized template. Import Type is FROM_ARCGIS. Target Metadata is the data 

set that needs metadata. Uncheck Enable automatic updates.

 

D. Synchronize  This process will draw information from the data and put it in the 

ArcGIS format xml. 

1. Highlight the correct data object in the Catalog Tree. 

2. Open the Synchronize Metadata tool in ArcToolbox (Conversion Tools -> 

Metadata -> Synchronize Metadata). The Source Metadata is the data set you are 

trying to document. Use the SELECTIVE option in the tool. See screen shots 

below: 
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E. Examine the results. Note that after the tool runs, ArcCatalog may 

automatically put the focus on the containing folder, not on the object just worked 

on. Click on the data in the Tree to re-highlight it. The Description tab should now 

show a lot of information that was captured automatically from the data. 
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F. Editing in ArcCatalog.  Open the metadata for editing by clicking the Edit 

button at the top of the Description tab 

   Now the metadata can be 

edited to add information to it. Most of the manual entry elements required for 

cataloging are listed below. More detailed lists of elements and contents for 

cataloging and for full documentation can be found in lists published by NJGIN, and 

in Appendices to this document. In the Editor, first look for items marked with a red 

x in the section list on the left side of the tab. Not all of these need to be fixed 

completely, but they are a place to start.  

IMPORTANT: Be careful which red x you click on! 

  

To cancel bad edits, Exit without saving to revert to the way the metadata were the 

last time they were saved. For additional field guidance, hover cursor over the field 

and look in the help bar at the bottom of the Description pane. 

BE 

CAREFUL – 

THESE 

DELETE! 

These indicate missing 

information. 
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1. Title: This should be succinct but informative. It should give the reader a good 

clue to the contents of the data set. Do not leave it as just the filename of the 

data set (which is what ArcCatalog captures.) It may be helpful to readers to 

include a well-known filename near the end of the Title.  

2. Summary (Purpose): The “why” of the data set, i.e. the business reason for its 

creation. 

3. Description (Abstract): A paragraph or two conveying the “what” of the data set. 

Should be intelligible to the non-specialist reader. 

4. Use Limitation (Use Constraints): Explain how the data should or should not be 

used; request attribution. Sample language is available for state agencies. If a 

liability disclaimer should appear on the AGOL Item page, include it here. 

5. Bounding Box (Bounding Coordinates): If the metadata are associated with the 

relevant data, should be filled in automatically by ArcCatalog during 

synchronization. If not, must be filled in manually in Item Description section, 

using geographic coordinates in signed decimal degrees. Be sure to check the 

box for “Extent Contains the Resource.” 

6. Topic Categories: pick one. Do not use Boundaries unless the data set is 

administrative or political boundaries, such as municipal boundaries or voting 

districts. See Appendix for definitions. 

7. Content Type: Pick from the list and check the box for Export as Resource 

Description. This is required for proper function in old NJGIN2 catalog, optional 

but useful in ArcGIS Online. 

  

8. Theme Keyword(s): Add a Theme Keywords section, then enter subject keyword 

words or phrases that a user might choose when searching for this data item. 

Separate them with newlines. If keywords are from a published vocabulary, add a 

Thesaurus Citation in the same section. Otherwise, skip it. 

9. Place Keyword(s): The most important / relevant one needs to be first in the list. 

For statewide data, should be “New Jersey”. For county data, the county name 

and state, e.g. “Sussex County, New Jersey”. 

10. Tags: Copy all keywords into the Tags field (in Item Description sub-section.) 

11. FGDC Geospatial Presentation Form: Pick from list. 

12. Publication date and edition:  Please be sure the publication date reflects the 

latest release of the data, not the original release. Publication date is the ONLY 

date that can be counted to persist through crosswalks to other metadata 

formats. Please be sure to change this date every time metadata are updated for 

a discrete re-release. This becomes more and more important as the data world 

becomes more interconnected. It is optional to put any brief information about 
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previous releases in edition, which is a free text field. Sample language: “Third 

edition; original publication date 2009-01-15.” More-involved histories can go in 

Supplemental Information or Process Steps. Use of Created and Revised dates is 

optional; they will persist when metadata are shared with ArcGIS products but 

will not translate into exported FGDC CSDGM standard metadata. 

13. Citation Contact Information for Originator: fill in fully-described 

organization, and person’s name if applicable. This should be the organization 

and/or person who defined the requirements for the data set. There is no harm 

in completing all the contact information to create a re-useable contact. 

14. Citation Contact Information for Publisher: Fill in fully-described organization, 

City and State at least. There is no harm in completing all information to create a 

re-useable contact. 

15. Metadata Date Stamp: initially fills in automatically, but can be changed. 

16. Metadata Contact Information: fill in a name, full organization, and full contact 

information either for the metadata author, or for someone who will continue to 

be able to answer questions about the metadata. 

17. Status/Progress of data set development: under Resource Details, pick the 

appropriate choice. 

18. Credits: Copy in Originator and Pubisher, then add anyone else who should 

receive credit/thanks (partners, funding sources, etc.) 

19. Temporal Extent (Time Period of Content date(s)): in the ArcGIS Editor, create a 

new Extent section, separate from the Extent section for bounding coordinates. 

To the new section, add Temporal Period Extent or Temporal Instant Extent 

and fill in date(s). If you can establish when the data matched the real world, 

Description of the Extent is Ground Condition. Otherwise, use Publication Date 

or a custom entry.  

20. Maintenance [and] Update Frequency: pick the appropriate choice. Unless there 

is a process in place for formal change detection, editing, and publishing, “as 

needed” probably is not appropriate. 

21. Access Constraints, Use Constraints, Distribution Liability: Standardized 

language across an organization is appropriate in many cases, so these are good 

to put in a template. Sample language is available from NJOIT – OGIS. In the 

ArcGIS Editor, these are in the following locations: 

a) Access Constraints    Resource -> Constraints -> Legal Constraints -> Other 

Constraints (leave out if none.) 

b) Use Constraints    Resource -> Constraints -> General Constraints -> Use 

Limitation AND/OR Overview -> Item Description -> Use Limitation (4, above) 

c) Distribution Liability    Resource -> Constraints -> Legal Constraints -> Use 

Limitation.  

22. Distribution Information: In AGOL and Open Data, the provider is displayed 

with the Item, from the Esri account information. Skip this section if the 

metadata won’t be used elsewhere. However, if the metadata will be used 

elsewhere, for Distribution Information to travel with the data it will need to be 

filled in. If help is needed, see ArcGIS Desktop Help topic Illustrated guide to 

complete FGDC metadata, and jump to the Distribution Information section, to 

see how to fill out the missing parts, and/or consult the complete element list in 

Appendix III. It is a bit confusing because the ArcGIS editor is formatted to allow 
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editors to fill this in for FGDC AND ISO metadata export, and they require two 

different organization schemes. For FGDC CSDGM, almost all the info needs to be 

filled out within the Distributor entry. However, URLs go in two places: 

Distribution -> Distributor -> Digital Transfer Options -> Online Resource -> 

Linkage 

 

Distribution -> Digital Transfer Options -> Online Resource -> Linkage 

 

Use the second one above for a direct download URL, if available and/or a 

general information URL (element is repeatable.) This one ends up in Section 1 – 

Identification Information of exported FGDC CSDGM metadata. If the metadata 

are on the old NJGIN catalog, the first entry also will be provided as a direct 

linkage attached to the metadata Title when it is returned from a search. If the 

ArcGIS metadata are uploaded to ArcGIS Online, an entry will be filled in 

automatically. 

 

Use the first one above for all kinds of direct access. This one ends up in 

Section 6 – Distribution Information of exported FGDC CSDGM metadata. 

 

For downloadable data, the same URL will be in two places. 

23. Mandated creators, including NJ State vendors: are required to provide more 

information than just the essential elements for cataloging. There are separate 

help documents to assist with creating fuller metadata.  

a) A full list of elements for compliant metadata is published by NJGIN in 

several formats. The complete list of FGDC CSDGM elements in Standard 

order is in a separate document. 

https://njgin.state.nj.us/oit/gis/NJ_NJGINExplorer/docs/MD_Documentation_elements_FGDC_CSDGM.pdf 

b) Appendix III lists the full documentation checklist elements that require 

manual entry in the ArcGIS editor. This is a shorter list because some of the 

required elements are filled in during metadata synchronization with the 

data. 

c) Help with Fields (Entity and Attribute Information) is available in the full 

element list in Appendix III. If there already is a detailed data dictionary in 

tabular format, there are alternative ways of satisfying the requirements for 

the Fields section. Contact the human help listed below for more 

information. 

d) Help with sample language for Constraints and Distribution Liability is 

available from NJGIN. 

G. Alternative: editing in ArcGIS Online. ArcGIS Online has a metadata editor. 

It can be used instead of ArcCatalog to fill in most of the required manual entry 

information, or as a supplement to ArcCatalog to make minor updates after 

uploading full metadata. However, there is a bug in the AGOL editor that omits 

Publisher and Publication Place. The AGOL Editor also cannot extract as much 

information directly from the data and there is no automated thumbnail tool. 

https://njgin.state.nj.us/oit/gis/NJ_NJGINExplorer/docs/MD_Documentation_elements_FGDC_CSDGM.pdf
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H. Create thumbnail 

1. Automatic via ArcCatalog (easy): select the data set in the Catalog Tree. Select 

the Preview tab in the Contents pane and click the thumbnail button on the 

Geography toolbar.   

2. A branded, custom thumbnail is strongly recommended for vetted State data to 

be registered in ArcGIS Online. The human help listed below can provide further 

information. 

3. Custom: Create a customized view of the data in ArcMap, and a custom image.  

a) Set the layout Data Frame Properties to Size width = 2.08in, height = 1.38in. 

This will yield a 200 x 133 pixel image. 

b) Add a base map or layer. Symbolize data and zoom to a pleasing scale. 

Check in layout view. Add a branding banner image if desired. 

c) Choose File -> Export Map, with options as follows: 

d) Save as type JPEG 

e) Resolution 96 dpi 

f) Clip output to graphics extent ON 

g) Once the JPEG file has been created, switch to ArcCatalog, select the feature 

class, and invoke the ArcGIS metadata editor. Import the image by using the 

Update button under the thumbnail or placeholder. If further info is needed, 

see ArcGIS Help instructions Creating a thumbnail from the Description tab. 

I. Producing metadata for ArcGIS Online: 

1. Incorporate a custom thumbnail or create an automatic thumbnail using 

ArcCatalog (instructions for both above). 

2. Consider adding keywords/tags: any keywords put in keywords fields and 

copied into Tags in the metadata will be written into the AGOL item Tags (aka 

searchKeys), the first time you upload a metadata file. If you update existing 

metadata on AGOL by submitting a new, edited xml, any additional Tags may 

have to be copied in manually. 

3. Consider copying Originator and Publisher into Credits: This will enable them 

to show up in the AGOL Item front page. 

4. Consider cleaning out “private” information: several classes of information 

can be removed from the metadata record using the XSLT Transform tool 

(Conversion Tools -> Metadata.)  
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The tool requires an Input XSLT file to define the processing. Those files are 

installed with ArcMap/ArcCatalog. The file location on my Windows 7 PC is 

C:\Program Files (x86)\ArcGIS\Desktop10.3\Metadata\Stylesheets\gpTools\ . 

You might want to add an ArcCatalog Tree connection to this folder on your PC 

for easy access. 

 

Automatically-collected geoprocessing information can be removed by using the 

tool with remove geoprocessing history.xslt; references to computing platform 

addresses can be removed by using the tool with remove local storage info.xslt or 

remove local storage info strict.xslt. Note that each time the tool is run, the 

Source Metadata is the previous metadata, and the Output File is a new metadata 

xml file of the processed output metadata.  

 

The final file should be imported into association with the data, using the 

Toolbox Metadata Importer tool. See details in Things to Remember. 

 

5. If the AGOL Item is not an uploaded shapefile, create a standalone ArcGIS 

xml:  

a) Invoke the XSLT Transform tool. Use exact copy of.xslt for the Input. The 

Source will be either the metadata associated with the data, or a more 

cleaned-up xml file produced above. 

b) Name the output file to make it recognizable as ArcGIS metadata for the 

correct data set (e.g. Govt_admin_county_seat_3857_Arc.xml) 

6. Sign into AGOL and upload the standalone xml file. If the Item is created in 

AGOL by uploading a zipped shapefile with metadata, skip this step – AGOL will 

read in the .shp.xml. On the AGOL Content Item interface, a standalone xml file 

can be uploaded using the Metadata (-> Edit) button. When the editor interface 

comes up, click the Open or Overwrite button, which will allow browsing to the 

standalone file, and then upload the file. Then Save and Close. Then check the 

Item page to confirm changes. 

 
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Appendix I: A few nifty features and quirks of the ArcCatalog Editor 

 Contact Information – The ArcGIS metadata editor includes a Contacts Manager, which 

can save Contact Information paragraphs to a file on the PC or server where ArcGIS is 

installed. The contacts can then be re-used. When a metadata record is open in the 

Editor, the Contacts Manager (section) lists all the Contacts saved in the Manager file 

(first), and then all the additional ones in the current metadata record. You can save 

new ones or un-save old ones in this view. Un-checking will not delete the entry from 

the current metadata, just from the saved ones. When you load a saved contact 

somewhere in the ArcGIS editor, don’t forget to set/change the role for the new instance 

of use. If you are comfortable editing xml files in an xml or text editor, you can edit 

directly the file where the saved contacts are stored: at ArcGIS 10.x, the file is located 

at:  <user documents>/ArcGIS/Descriptions/contacts.xml 

 

 Synchronization – we are done struggling with manually entering Spatial Reference 

information. As long as there is a proper spatial reference on the data, ArcGIS will read 

it into the metadata. A lot of other information also gets read in this way, depending on 

how the synchronization is invoked. The full list of what can get synchronized for a 

feature class is below: 

o Title – gets file or feature class name 

o Bounding Coordinates in decimal degrees 

o Content Type as Downloadable Data  

o Presentation Format e.g. digital map 

o Dataset language as English (United States) 

o Spatial representation as vector (if it is polygons) 

o Processing environment (Windows build version etc) 

o ArcGIS Item properties, including file location (these are non-editable, but don’t get 

exported in the FGDC CSDGM xml) 

o Extents, both geographic coordinates and native coordinate system units 

o Spatial Reference, both EPSG reference and full instantiated elements 

o Spatial Data Properties (roughly equivalent to Spatial Data Organization) 

o Field names, aliases, and types 

o Metadata date stamps and scope 

 

 Synchronization options – some operations perform a set type of synchronization. If 

you synchronize manually, you can control what gets synchronized to some extent: 

o ALWAYS – Does not change an edited Title, but will fill it in if blank. 

o ACCESSED – Elements will be synchronized whenever an ArcGIS client accesses the 

data, even if ArcCatalog is set to not do this. The sync will reset some date stamps, 

for example, every time someone examines the data. Once ACCESSED is chosen, it is 

set for the data object and is difficult to change. 

o CREATED – If metadata are present but empty, does not fill elements. 

o NOT_CREATED – Will fill above elements if empty, and update some even if filled. 

Does not over-write edited Title or a manually-entered bounding box. 

o OVERWRITE – Overwrites all of the above, even if they have been edited by a human 

already (Existing readable Title gets destroyed.) However, existing attribute 

definitions are not destroyed. 
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o SELECTIVE – Overwrites the above with info from current data, except for Title and 

Content Type. 

 

 Date formats - In the ArcGIS editor, the date convention for ISO metadata is followed. 

Dates are YYYY-MM-DD. Times are hh:mm:ss . Most date fields are restricted in the 

editor to using the calendar date picker. If you do not know the month or day, establish 

a convention (e.g. use 2002-01-01 or 2002-12-31 if all you know is the year). When 

putting a date and/or time in a free text field, it makes sense to format it properly. 

When exporting to FGDC CSDGM xml, the contents of date/time fields will be translated 

to FGDC CSDGM format and stored that way in the xml. Contents of free text fields will 

remain as entered. The ArcGIS stylesheets display almost all dates in the ISO format if 

the date has been properly-formatted in an FGDC xml date field. 

 

 Error flags (little red x in editor section list) - A few of these may persist, even after 

completion of all the information necessary to produce FGDC CSDGM compliant 

metadata. The Quality and Lineage sections of the editor are the most frequent culprits. 

If you are pretty sure the information is complete but want to check, export an FGDC 

CSDGM xml and run it through the MP validation service to identify any missing info.  
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Appendix II: Required Cataloging Elements for NJGIN  

List below is in ArcCatalog Metadata Editor order. These are the minimum list of elements 

that will work well for cataloging. Fields marked # are filled during ArcCatalog 

synchronization or automatically by the editor, but can be changed. Fields marked * are 

commonly the same for many records and are candidates for template. 

Overview section 

Item Description sub-section 

o Title 

o Summary (Purpose) 

o Description (Abstract) 

o Use Limitation (Use Constraints) * 

o Bounding Box (4 coordinates) # 

Topics & Keywords sub-section 

o Topic Category (check box) 

o Content Type, and Resource Description check box 

o New Theme Keyword section, Theme Keywords (separate with comma or line break) 

o Theme Keyword Thesaurus (only if above keywords are from a published vocabulary) 

o Place Keyword 

(Resource) Citation sub-section 

o Title (same as above, edit only if necessary) 

o FGDC Geospatial Presentation Form 

o Dates -> Published (please be sure to change for each discrete data release) 

(Resource) Citation Contacts sub-section 

o Citation Contact (name and/or organization) and Role = Originator * 

o Citation Contact (name and/or organization, plus at least City and State), and 

Role = Publisher * 

 

Metadata section 

(Metadata) Details sub-section 

o Date Stamp # 

(Metadata) Contacts sub-section 

o Metadata Contact (name and/or organization) plus full contact information 

including email, and Role = Point of Contact * 

 

Resource section 

 (Resource) Details sub-section 

o Status (Progress) 

 (Resource) Extents sub-section, ADD A NEW EXTENT SUB-SECTION 

o Temporal Instant Extent Date or Temporal Period Extent Dates (Time Period of 

Content Date(s)) 

o Temporal … Extent Description: Ground Condition, Publication Date, or free text 

(Currentness Reference) 

(Resource) Maintenance sub-section 
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o Update Frequency (Maintenance and Update Frequency) 

(Resource) Constraints sub-section 

o Legal Constraints -> Use Limitation (Distribution Liability) * 

o Legal Constraints -> Other Constraints (Access Constraints); leave out if none. * 

(Resource) Distribution sub-section -> Digital Transfer Options -> Online Resource 

o Linkage (Online Linkage) Not required for ArcGIS Online access points. Required for 

other download and/or service points. 

 

  



 ArcGIS MD for AGOL from scratch 

Page 17 of 23   22-Oct-18 

Appendix III: Required Full Metadata Elements, Editor field list 

This list includes all the fields, in Editor order, that must be filled in or edited manually in 

the ArcCatalog Metadata Editor (or imported from a template) to produce full metadata per 

NJDEP/NJGIN required list. Warning: the following list does not include all the fields that 

may have outdated information in them, if the metadata were upgraded from an existing 

FGDC CSDGM record. 

A similar listing in other formats is available from NJGIN, including a list in standard 

element number order: Metadata full documentation element checklist for typical GIS vector 

data for NJ, FGDC CSDGM, at 

https://njgin.state.nj.us/oit/gis/NJ_NJGINExplorer/docs/MD_Documentation_elements_FGDC_CSDGM.pdf 

Overview section 

Item Description sub-section 

o Title 

o Summary (Purpose) 

o Description (Abstract) 

o Use Limitation 

Topics & Keywords sub-section 

o Topic Category (check box) 

o Content Type, and Resource Description check box 

o Place Keyword 

(Resource) Citation sub-section 

o Title (same as above, edit only if necessary) 

o FGDC Geospatial Presentation Form 

o Dates -> Published 

(Resource) Citation Contacts sub-section 

o Citation Contact (name and/or organization) and Role = Originator 

o Citation Contact (name and/or organization, plus at least City and State), and 

Role = Publisher 

 

Metadata section 

(Metadata) Contacts sub-section 

o Metadata Contact (name and/or organization) plus full contact information 

including email, and Role = Point of Contact 

 

Resource section 

 (Resource) Details sub-section 

o Status 

o Supplemental Information 

(Resource) Extents sub-section 

o Temporal Instant Extent or Temporal Period Extent, including date or dates and 

Description. The latter may be Ground Condition, Publication Date, or free text. This 

information must be in a completely separate Extent entry, not in the same one as 

the Bounding Box Extent. 

(Resource) Maintenance sub-section 

o Update Frequency 

https://njgin.state.nj.us/oit/gis/NJ_NJGINExplorer/docs/MD_Documentation_elements_FGDC_CSDGM.pdf
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(Resource) Constraints sub-section 

o Legal Constraints -> Use Limitation (Distribution Liability) 

o Legal Constraints -> Other Constraints (Access Constraints); leave out if none. 

(Data) Quality sub-section 

o Report Type -> Conceptual Consistency AND  Measure -> Description [Logical 

Consistency Report] 

o Report Type -> Completeness Omission AND Measure -> Description [Completeness 

Report] 

o Report Type -> Quantitative Attribute Accuracy AND Measure -> Description 

[Attribute Accuracy Report] 

o Report Type -> Absolute External Positional Accuracy AND Dimension -> horizontal  

AND Measure -> Description [Horizontal Positional Accuracy Report] 

o A second set of Absolute External Positional Accuracy report elements if Vertical 

Accuracy is pertinent. 

(Resource) Lineage sub-section 

o If published or archived source data or documents were used, for each one: 

 Source Description 

 Scale Denominator (only for paper maps, or data of known nominal scale) 

 Source Citation Title 

 Alternate Title [Source Citation Abbreviation] e.g. file name 

 FGDC Geospatial Data Presentation Form 

 Date Published for the Source 

 Edition (only if referenced by source documentation) 

 Source Citation Contact name and/or organization and Role =  Originator 

 Source Citation Contact name and/or organization, City, State, and 

Role = Publisher 

 Source Temporal Instant Extent or Temporal Period Extent, including date or 

dates and Description.  

o If detailed processing information is available, for each process step: 

 Process Description (include description of source(s) if not documented 

above) 

 Process Step Date (and time if relevant) 

 (Resource) Distribution sub-section 

Distributor sub-sub-section (BE CAREFUL TO CHOOSE THIS CORRECTLY – it is 

the second one of three.) 

 Distributor Contact organization and/or name, Role = Distributor, and full 

contact information 

 Ordering Process Fees 

 Available Date or Date Period  

 Ordering Instructions 

 Distribution Format -> Format Name 

 Distribution Format -> Format Version 

 Digital Transfer Options -> Online Resource -> Linkage (direct access URL for 

download or service consumption) 

Digital Transfer Options sub-sub-section (BE CAREFUL TO CHOOSE THIS 

CORRECTLY – it is the third one of three.) 
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 Online Resource -> Linkage Repeatable element. First one should be a direct 

access URL if there is one. Add repeating elements for informational Web 

page, organization main Web page, etc. 

 (Resource) Fields sub-section – Entity and Attribute Information 

o Label (change the synchronized default to something more descriptive of the Entity) 

o Entity Type -> Definition 

o Entity Type -> Definition Source 

o For each field (Attribute): 

 Label 

 Definition  

 Definition Source 

 ONE of  Range Domain -> Minimum AND -> Maximum  

    Codeset Domain -> Name AND -> Source 

    Unrepresentable Domain   

OR 

One or more Enumerated Domain, including for each  

-> Value, ->Definition, ->Definition Source 

 
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Appendix IV: Pick lists for NJGIN 

A. ISO 19115 Topic Category codes
1

: For all metadata records, include one of the 

following ISO Topic Category codes (text), which expresses the Primary Theme of the 

data set, map, service, or application. In the ArcCatalog Editor, this entry is a check box; 

the keyword and the Thesaurus entries are made automatically by the editor and 

exporter. Numeric (three digit numbers as text) codes are provided for reference only. 

 

Theme Keyword Thesaurus: ISO 19115 Topic Category 

 

Theme Keywords: 

 

o biota   002    for naturally-occurring flora and fauna, such as wildlife, biological 

sciences, ecology, wilderness, sea life, wetlands, habitats 

 

o boundaries   003     for administrative and political boundaries, i.e. legal land 

descriptions 

 

o climatologyMeteorologyAtmosphere   004     for atmospheric processes and 

phenomena, such as cloud cover, weather, atmospheric conditions, climate change, 

precipitation 

 

o economy   005     for economic activities or employment, such as labor, revenue, 

commerce, industry, tourism, ecotourism, forestry, fisheries, commercial or 

subsistence hunting, exploration and exploitation of  minerals, oil, gas 

 

o elevation   006     for height above or below sea level, such as altitude, bathymetry, 

digital elevation models, slope, and products derived from the preceding 

 

o environment   007     for environmental resources, protection, and conservation, 

such as pollution, waste storage and treatment, environmental impact assessment, 

environmental risk, and nature reserves 

 

o farming   001     for agriculture and farming, including the rearing of animals or 

cultivation of plants. For example, irrigation, aquaculture, herding, pests and 

diseases affecting crops and livestock 

 

o geoscientificInformation   008     for geological, geophysical, and other earth 

science information, such as minerals, rock structure, rock composition, rock origin, 

earthquakes, volcanic activity, landslides, gravity, soils, permafrost, hydrogeology, 

erosion 

 

o health   009     for human health and disease, health services, human ecology, and 

safety, such as human disease, human illness, factors affecting health, hygiene, 

mental and physical health, substance abuse 

 

                                                           
1 Derived from ISO Draft International Standard: Geographic information -- Metadata (ISO/DIS 19115), 2001, 

Section B.5.27 MD_TopicCategoryCode<<CodeList>> (pp. 85-86); Creating and Using Metadata Services, 2002, 

ESRI, Chapter 4 – Publishing metadata in ArcCatalog; and NOAA EDM ISO 19115 and 19115-2 CodeList 

Dictionaries - MD_TopicCategoryCode at https://geo-ide.noaa.gov/wiki/index.php?title=ISO_19115_and_19115-

2_CodeList_Dictionaries#MD_TopicCategoryCode. Numeric domain codes are from https://geo-

ide.noaa.gov/wiki/index.php?title=ISO_Topic_Categories. 
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o imageryBaseMapsEarthCover   010     for base maps, such as land cover, 

topographic maps, classified and unclassified images. 

 

o intelligenceMilitary   011      for military bases, structures, and activities, such as 

barracks, training grounds, military transportation, military information collection 

 

o inlandWaters   012      for inland water features and drainage systems, such as 

rivers, glaciers, salt lakes, water use plans, dams, currents, floods, water quality, 

hydrographic charts 

 

o location    013     for positional information and services, such as addresses, 

geodetic networks, postal zones and services, control points, place names 

 

o oceans   014     for features and characteristics of salt water bodies excluding 

inland waters, such as tides, tidal waves, coastal information, reefs 

 

o planningCadastre   015     for land use, such as zoning maps, cadastral surveys, 

land ownership 

 

o society   016     for characteristics of societies and cultures, such as natural 

settlements, anthropology, archaeology, education, traditional beliefs, manners and 

customs, demographic data, crime and justice, recreational areas and activities, 

social impact assessments, census information 

 

o structure   017     for man-made construction, such as buildings, museums, 

churches, factories, housing, monuments, and towers 

 

o transportation   018     for transportation networks, the means and aids for 

conveying people and goods, such as roads, airports, airstrips, shipping routes, 

tunnels, nautical charts, vehicle or vessel location, aeronautical charts, railways 

 

o utilitiesCommunication   019     for energy, water, and waste systems, and 

communications infrastructure and services, such as hydroelectricity, geothermal, 

solar, and nuclear sources of energy, water purification and distribution, sewage 

collection and disposal, electricity and gas distribution, data communication, 

telecommunication, radio, and communication networks. 

 

o extraTerrestrial        for region more than 100 km above the surface of the Earth 

 

o disaster       for information related to disasters. Examples: site of the disaster, 

evacuation zone, disaster-prevention facility, disaster relief activities. 

 

B. Content Type codes for Resource Description <resdesc>  

Use EXACTLY ONE of the following entries, exactly as shown. In the ArcCatalog 

Editor, this is a check box. 

o Live Data and Maps 

o Downloadable Data 

o Offline Data 

o Static Map Images 

o Other Documents 

o Applications 

o Geographic Services 

o Clearinghouses 

o Geographic Activities 
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C. NJ Framework data layers keywords Use one of these only if the subject 

applies, your organization is the authoritative source, and the data originate with 

your organization (not copies of data from elsewhere). Put in a separate section, 

with Theme Keyword Thesaurus name “NJGIN” 

o njfw_geocontrol Geodetic control 

o njfw_orthophoto Geo-referenced images of the Earth’s surface 

o njfw_boundaries Boundaries of federal, state, local, tribal governments as 

reported/certified to the US Census Bureau. 

o njfw_cadastral Geographic extent of right, title and interest in real 

property (tax parcels, zoning, easements, etc.) 

o njfw_hydro Surface water features 

o njfw_elevation Geo-referenced digital representations of vertical position 

above or below a datum surface 

o njfw_transport Geographic locations, interconnectedness, and 

characteristics of the transportation system 

o njfw_critical Locations of the following: 

 Emergency Operations Centers 

 Police Stations 

 Fire Stations 

 Emergency Medical Services Stations 

 Coverage Areas for the above 

 Hospitals 

 Schools 

 Colleges and Universities 

 Day Care Facilities 

 Government Buildings 

 Power Generating Plants 

 Power Substations 

 Armories 

 Military Sites 

 Communication Towers 

 Telecommunication Sites 

 Utility Transmission Lines 

 Sports Arenas / Stadiums 

 TCPA Sites 

 SARA Sites 

 Ingestion Zones 

 Prisons 

 Evacuation Routes 

 Drinking Water Intakes 

 Sewage Pumps 

o njfw_lulc Land use and land cover conditions 

 

D. Tags for Federal Project Open Data (POD) (enter in Theme 

Keywords) 

o public   data are available or could be made available to the public 

o restricted public  available under certain use restrictions 

o non-public   data not available to the public 
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 

Questions may be directed to: 

Edith Konopka     Edith.Konopka@tech.nj.gov       609-777-3774 

NJ Office of Information Technology, Office of Geographic Information Systems 

OR 

NJGIN administrator  njgin@oit.nj.gov   609-633-9103 

OR 

Daniel Oliva     Daniel.Oliva@dep.nj.gov       609-777-4324 

NJ Department of Environmental Protection, Division of Information Technology, Bureau of GIS 

 

Change History 

Version 1.6 released 22 October 2018 – Changes to Editing in ArcCatalog to reflect NJGIN Core. Move 

Metadata Importer tool help to Things to Remember. Other editorial changes. 

Version 1.4 released 29 August 2018 – Changes to Appendices I, IV, and V. Expanded ISO Topic 

Category list. Various editorial changes, including simplified workflow. 

Version 1.2 released 12 June 2018 – Re-ordered some material. Moved use of Metadata Importer tool 

to Appendix I. Expanded use of XSLT Transformation tool. 

Version 1.1 released 17 May 2018 - Added use of XSLT Transformation tool; edits to Appendix 

information 

 
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