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ArcGIS Pro Metadata for ArcGIS Online, FGDC Style, from Scratch 

Version 1.0 

https://geoapps.nj.gov/njgin/documents/MD_ArcGIS_from_scratch_using_Pro_for_AGO.pdf 

This document is intended to help data and metadata providers who contribute to the State of 
New Jersey ArcGIS Online / Open Data site that is part of the New Jersey Geographic Information 
Network (NJGIN), and to partner sites. As of Fall 2022, this site is set to use FGDC style ArcGIS 
metadata.  
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 Set up tools: Configure ArcGIS Pro 

 Gather information about the data 

 Synchronize metadata with data 

 Edit the metadata to add information needed for the intended purpose 

 Thumbnail, easy or custom 

 Create file for AGO 

  

https://geoapps.nj.gov/njgin/documents/MD_ArcGIS_from_scratch_using_Pro_for_AGO.pdf
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Things to Remember 

 If starting with existing metadata in FGDC CSDGM format, instead of this document, 

please refer to Transitioning from FGDC to ArcGIS metadata, FGDC style for ArcGIS 

Online, Using ArcGIS Pro. There are several very important differences in workflow.  

 Date formatting: for a date in a free text field, enter in this format:  

2018-02-15.  

 Change Publication Date for re-release of updated data. 

 Need to transfer metadata contents with no changes? NJOGIS has a downloadable 

toolbox for Pro. Email to njgin@oit.nj.gov for instructions.  

 For submissions of metadata to ArcGIS Online, a cleaned-up record is important. See 

Section I, Producing Metadata for ArcGIS Online. 

Step by Step Instructions 

A. Essential tools - set up in preparation 

1. These instructions are written for ArcGIS Pro 2.9. We have not been able to test 
yet for ArcGIS Pro 3. 
 

2. Remember that whatever object is highlighted in the Catalog tab of the Catalog 
view, will be active, and visible in Details panel. Its metadata will be visible in 
Metadata tab and will be opened for editing if you click the Edit button in the ribbon 
Metadata section.  

ttps://geoapps.nj.gov/njgin/documents/MD_Transitioning_FGDC_to_ArcGIS_Pro_for_AGO.pdf
ttps://geoapps.nj.gov/njgin/documents/MD_Transitioning_FGDC_to_ArcGIS_Pro_for_AGO.pdf
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3. Set up ArcGIS Pro for FGDC style metadata. First set the Metadata style at File ->  
Options -> Application -> Metadata. In the same form, check ON to allow 
geoprocessing history to be deleted. 

Next, set the application to NOT write geoprocessing steps to the metadata, at 
File -> Options -> Application -> Geoprocessing:  

 
4. ArcGIS Pro Help for using the Metadata Editor to produce FGDC CSDGM style 

metadata: There are various useful help topics in the web help under Data -> Data -> 
Metadata. The one you are most likely to need repeatedly is Create FGDC CSDGM 
metadata. You might want to “Favorite” that one. The path from the Pro ? button is a 
bit different. 

5. For advanced work on metadata, there are some optional tools listed in Appendix V.  

OFF 
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B. Gather information about the data set 

1. If the data have not been created yet: Set up a way to collect notes or a formal 
project log, depending on how large and complicated the process will be. Twenty 
Questions about Geospatial Data, available from NJGIN as a PDF file and as an MS 
Word file, may be of help. 
 

2. If you created the data: Review notes or project log. If you wrote any FGDC CSDGM 
metadata, instead of this document consult Transitioning from FGDC to ArcGIS 
metadata, FGDC style for ArcGIS Online, also available from NJGIN. 
 

3. If someone else created the data: Request notes and/or an interview. If you are not 
sure what to ask, try using Twenty Questions about Geospatial Data (see above.) 
Also, double-check to see if the data have FGDC CSDGM metadata attached already, 
which is easiest to do in ArcCatalog. If so, extensive information will be visible at the 
very bottom of the ArcCatalog Description tab in a grey font; expand the section 
entitled FGDC Metadata (read only). If extensive FGDC CSDGM metadata are present, 
see 2. above. 
 

4. If Esri tools were used to create the data: Review any geoprocessing information 
that was captured automatically and is visible either in Pro or on the ArcCatalog 
Description tab. If there is extensive information there, back it up to a standalone 
xml.  
a) In Pro, use Catalog view -> ribbon section Metadata -> Save As -> Save As 

XML -> All Content. 
b) In ArcCatalog, create a blank xml (see screen shot below) and use the 

ArcCatalog Metadata Importer tool (in Conversion tools -> Metadata; looks like a 
hammer) to copy the metadata to the target blank xml. 
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C. Template  If several data sets from the same organization need metadata, it is useful 

to create a generic record (in ArcGIS xml) that includes the information that will be the 
same for all of them, such as the Metadata Contact, the Originator, the Publisher, Access 
and Use Constraints, Distribution Liability, etc.  
1. Write a metadata record for the first data set with just the common information in it. 

See details below on Metadata Editing in ArcGIS Pro. 
2. Make sure the first data set is still highlighted in the Catalog tab after closing the 

Metadata Editor. In the Pro ribbon section Metadata, choose Save As -> Metadata 
Template; save the output xml in a convenient location with a distinctive name. Then 
go back to editing the metadata attached to the data set, making a complete 
metadata record for that data set. 

3. For second data set that has no metadata yet, highlight it in the Catalog tab. Then 
on the Pro ribbon section Metadata, choose Import. Browse to choose the template 
xml created above. Set the type of metadata to import to ArcGIS Metadata. 

 
D. Synchronize  This process will draw information from the data and put it in the 

ArcGIS format xml. Warning: synchronizing in Pro will obliterate the metadata Title 
entry. Save the contents of Title somewhere else if you intend to re-use them. 

1. Highlight the correct data set in the Catalog tab. 
2. In the ribbon section Metadata, use the Synchronize button.  

E. Examine the results.   
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F. Metadata Editing in ArcGIS Pro.  In Catalog view, highlight the data set in the 

Catalog tab. The metadata should be visible in the Metadata tab of the Details panel, 
and the ribbon should show the Metadata section. Start the Metadata Editor by clicking 
the Edit button on the ribbon. The Editor opens in a new tab in the Details panel. 

 

The ArcGIS Metadata Editor in Pro works much like that in ArcCatalog but with a slightly 
different appearance. One important difference is that you can save your work without 
closing the Editor. Do so often to avoid losing work. To exit the Editor, close the tab in 
the Details panel. 
 

 
 
Most of the manual entry elements required for NJGIN Core are listed below. More 
detailed lists of elements and contents for NJGIN Core (metadata “lite”) and for full 
documentation can be found in lists published by NJGIN, and in Appendices to this 
document.  
 
To cancel bad edits, close the Editor tab without saving, to revert to the way the 
metadata record was the last time it was saved. 
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IMPORTANT: Be careful which red x you click on!  

 

1. Title: This should be succinct but informative. It should give the reader a good clue 
to the contents of the data set. Do not leave it as just the filename of the data set 
(which is what ArcGIS Pro captures.) It may be helpful to readers to include a well-
known filename near the end of the Title.  

2. Summary (Purpose): The “why” of the data set, i.e. the business reason for its 
creation. 

3. Description (Abstract): A paragraph or two conveying the “what” of the data set. 
Should be intelligible to the non-specialist reader. 

4. Use Limitation (Use Constraints): Explain how the data should or should not be 
used; request attribution. Sample language is available from NJGIN for state 
agencies. If a liability disclaimer should appear on the AGO Item page, include it 
here. 

5. Bounding Box (Bounding Coordinates): If the metadata are associated with the 
relevant data, should be filled in automatically by Pro during metadata 
synchronization. If not, must be filled in manually in Item Description section, using 
geographic coordinates in signed decimal degrees. Be sure to check the box for 
“Extent Contains the Resource.” 

6. Topic Categories: pick one, or at most, two. Do not use Boundaries unless the data 
set is administrative or political boundaries, such as municipal boundaries or voting 
districts. See Appendix IV for definitions. 

BE 
CAREFUL – 
THESE 
DELETE! 

These indicate missing 
information. 
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7. Content Type: Pick from the list. 

 

8. Theme Keyword(s): Add a Theme Keywords section, then enter subject keyword 
words or phrases that a user might choose when searching for this data item. 
Separate them with newlines. If keywords are from a published vocabulary, add a 
Thesaurus Citation in the same section. Otherwise, skip it. 

9. Place Keyword(s): The most important / relevant one needs to be first in the list. 
For statewide data, should be “New Jersey”. For county data, the county name and 
state, e.g. “Sussex County, New Jersey”. 

10. Tags: Copy all keywords into the Tags field (in Item Description sub-section,) unless 
the complete set is there already. The first time you save keywords they should all 
be added, but if you then add keywords, they may need to be added to Tags 
manually. 

11. FGDC Geospatial Presentation Form: Pick from list. 
12. Publication date and edition:  Please be sure the publication date reflects the latest 

release of the data, not the original release. Publication date is the ONLY date that 
can be counted to persist through crosswalks to other metadata formats. Please be 
sure to change this date every time metadata are updated for a discrete re-release. It 
is optional to put any brief information about previous releases in edition, which is a 
free text field. Sample language: “Third edition; original publication date 2009-01-
15.” More-involved histories can go in Supplemental Information or Process Steps. 
Use of Created and Revised dates is optional; they will persist when metadata are 
shared with ArcGIS products but will not translate into exported FGDC CSDGM 
standard metadata. 
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13. Citation Contact Information for Originator: fill in fully-described organization, 
and person’s name if applicable. This should be the organization and/or person who 
defined the requirements for the data set. There is no harm in completing all the 
contact information to create a re-useable contact. 

14. Citation Contact Information for Publisher: Fill in fully-described organization, City 
and State at least. There is no harm in completing all information to create a re-
useable contact. 

15. Metadata Date Stamp: fills in automatically. If edited manually, must be updated 
manually thereafter. 

16. Metadata Contact Information: fill in a name, full organization, and full contact 
information either for the metadata author, or for someone who will continue to be 
able to answer questions about the metadata. 

17. Status/Progress of data set development: under Resource Details, pick the 
appropriate choice. 

18. Credits: Include Originator and Pubisher, then add anyone else who should receive 
credit/thanks (partners, funding sources, etc.) 

19. Temporal Extent (Time Period of Content date(s)): in the Pro Metadata Editor, 
create a new Extent section, separate from the Extent section for bounding 
coordinates. Don’t add this information to the same Extent section that contains the 
bounding coordinates. To the new section, add Temporal Period Extent or 
Temporal Instant Extent and fill in date(s). If you can establish when the data 
matched the real world, Description of the Extent is Ground Condition. Otherwise, 
use Publication Date or a custom entry. Warning: although the editor looks as if the 
geographic extent for searching could be entered here, it cannot; the underlying xml 
will not be created correctly and won’t work in AGO. If bounding coordinates are still 
needed, go back to Overview -> Item Description. 

20. Maintenance [and] Update Frequency: pick the appropriate choice. Unless there is 
a process in place for formal change detection/reporting, editing, and publishing, 
don’t use as needed. 

21. Access Constraints, Use Constraints, Distribution Liability: Standardized 
language across an organization is appropriate in many cases, so these are good to 
put in a template. Sample language is available from NJOGIS. In the Pro Editor, these 
are in the following locations: 
a) Access Constraints    Resource -> Constraints -> Legal Constraints -> Other 

Constraints (leave out if none.) 
b) Use Constraints    Resource -> Constraints -> General Constraints -> Use 

Limitation AND/OR Overview -> Item Description -> Use Limitation (4, above, it 
appears in two places in the Editor) 

c) Distribution Liability    Resource -> Constraints -> Legal Constraints -> Use 
Limitation. At NJOGIS, we refer the reader to Use Constraints, and put all the 
language there. 

22. Distribution Information: In AGO and Open Data, the provider is displayed with the 
Item, from the Esri account information. Skip this section if the metadata won’t be 
used elsewhere. However, if the metadata will be used elsewhere, for Distribution 
Information to travel with the data it will need to be filled in. If help is needed, see 
Pro Help topic Create FGDC CSDGM metadata, and jump to the Distribution 
Information section, to see how to fill out the missing parts, and/or consult the 
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complete element list in Appendix III. It is a bit confusing because the ArcGIS editor 
is formatted to allow editors to fill this in for FGDC AND ISO metadata export, and 
they require two different organization schemes. For FGDC CSDGM, almost all the 
info needs to be filled out within the Distributor entry. However, URLs go in two 
places: 

Distribution -> Distributor -> Digital Transfer Options -> Online Resource -> Linkage 
 
Distribution -> Digital Transfer Options -> Online Resource -> Linkage 
 
Use the second one above for URL(s) for general program information, 
organization’s main website, and the like (element is repeatable.) This one ends up 
in Section 1 – Identification Information of exported FGDC CSDGM metadata.  
 
Use the first one above for all kinds of direct data access. This one ends up in 
Section 6 – Distribution Information of exported FGDC CSDGM metadata. 

23. Mandated creators, including NJ State vendors: are required to provide more 
information than just NJGIN Core. There are separate help documents to assist with 
creating fuller metadata.  
a) Appendix III lists the full documentation checklist elements that require 

manual entry in the Pro editor. This is a shortened list because some of the 
required elements are filled in during metadata synchronization with the data. 

b) Help with Fields (Entity and Attribute Information) is available in the full 
element list in Appendix III. If there already is a detailed data dictionary in 
tabular format, there are alternative ways of satisfying the requirements for the 
Fields section. Contact the human help listed below for more information. 

c) Help with sample language for Constraints and Distribution Liability is 
available from NJGIN. 

d) A full list of elements for compliant metadata is published by NJGIN in several 
formats. The complete list of FGDC CSDGM elements in Standard order is in a 
separate document. 
https://njgin.state.nj.us/oit/gis/NJ_NJGINExplorer/docs/MD_Documentation_elements_FGDC_CSDGM.pdf 

G. Alternative: editing in ArcGIS Online. ArcGIS Online has a metadata editor. It 

can be used instead of ArcGIS Pro to fill in most of the required manual entry 
information, or as a supplement to Pro to make minor updates after uploading full 
metadata. However, there is a bug in the AGO editor that omits Publisher and 
Publication Place. The AGO Editor also cannot extract as much information directly from 
the data and there is no automated thumbnail tool. 
 

H. Create thumbnail 

1. Automatic via Pro (easy): Open Pro in Catalog View, select the data set in the Catalog 
View, Catalog tab. Preview the Geography in the Details panel. The Catalog View 
Preview supratab should appear above the ribbon.  
 

https://njgin.state.nj.us/oit/gis/NJ_NJGINExplorer/docs/MD_Documentation_elements_FGDC_CSDGM.pdf
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Click on it to change the ribbon and expose the Thumbnail group.  

 

 
 
Navigate the Geography map to a suitable scale.  Add/change/remove basemap as 
seems best.  
 
Click the Thumbnail Create button. Then click on the Catalog tab (next to the active 
Project tab) to get back to Catalog view.  In the Details panel switch to the Metadata 
tab; the new thumbnail should be visible. 
 

A branded, custom thumbnail is strongly recommended for vetted, authoritative data for 
ArcGIS Online. Further help if needed is available from NJGIN. 
 
Any image can be used as a thumbnail; it need not be a map. Just use the correct shape 
(3:2 rectangle). 

 
2. Custom map: Create a customized view of the data in a Pro map, and a custom 

image.  
a) Set the layout Data Frame Properties to Size that will produce a 600 pixel wide 

by 400 pixel high image and will preview close to the final product. However, 
keep in mind that it is going to be displayed quite small in most cases. Working 
in a small dimension may help you produce a suitable thumbnail. 

b) Add a base map or layer. Symbolize data and zoom to a pleasing scale. Check in 
layout view. Add a branding banner image if desired. 

c) Choose Share -> Export Map, with options as follows: 
d) Save as type PNG 
e) Image Size 600 pixels high, 400 pixels wide 
f) Once the PNG file has been created, switch to Catalog view, invoke the Pro 

Metadata Editor, then import the image by using the Update button under 
the thumbnail or placeholder. If further info is needed, see Pro Help 
instructions Create a thumbnail. 
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I. Producing metadata for ArcGIS Online: 

1. Incorporate a custom thumbnail or create an automatic thumbnail using Pro 
(instructions for both above). 

2. Consider adding keywords/tags: any keywords put in keywords fields and copied 
into Tags in the metadata will be written into the AGO item Tags (aka searchKeys), 
the first time you upload a metadata file. If you update existing metadata on AGO by 
submitting a new, edited xml, any additional Tags may have to be copied in 
manually. 

3. Check that Originator and Publisher are included in Credits: This will enable 
them to show up in the AGO Item front page. 

4. Consider cleaning out “private” information: several classes of information can be 
removed from the metadata record using the Metadata -> Save As -> Save As XML 
function. Pick your preferred choice by reading the pop-up tool tips. 
 

 
 

This produces a standalone ArcGIS xml that can be imported into association with 
the data set, and/or uploaded to AGO. 
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Appendix I: Features and Quirks of the ArcGIS Pro Metadata Editor 

 Contact Information – The ArcGIS metadata editor includes a Contacts Manager, which can 
save Contact Information paragraphs to a file on the PC or server where ArcGIS is installed. 
The contacts can then be re-used. When a metadata record is open in the Editor, the 
Contacts Manager (section) lists all the Contacts saved in the Manager file (first), and then 
all the additional ones in the current metadata record. You can save new ones or un-save 
old ones in this view. Un-checking will not delete the entry from the current metadata, just 
from the saved ones.  

 
When you load a saved contact somewhere in the ArcGIS editor, don’t forget to set/change 
the role for the new instance of use. If you are comfortable editing xml files in an xml or 
text editor, you can directly edit the file where the saved contacts are stored: at ArcGIS Pro 
2.9 the file is located at:  <user documents>/ArcGIS/Descriptions/contacts.xml 
 

 Synchronization – we are done struggling with manually entering Spatial Reference 
information; in fact, the ArcGIS Pro Metadata Editor does not allow edits to it. If there is a 
proper spatial reference on the data, ArcGIS will read it into the metadata, in addition to a 
lot of other information also gets read in this way. The full list of what can get synchronized 
for a feature class is below: 
o Title – gets file or feature class name 
o Bounding Coordinates in decimal degrees 
o Content Type as Downloadable Data  
o Presentation Format e.g. digital map 
o Dataset language as English (United States) 
o Spatial representation as vector (if it is polygons) 
o Processing environment (Windows build version etc) 
o ArcGIS Item properties, including file location (these are non-editable, but don’t get 

exported in the FGDC CSDGM xml) 
o Extents (spatail,) both geographic coordinates and native coordinate system units 
o Spatial Reference, both EPSG reference and full instantiated elements 
o Spatial Data Properties (roughly equivalent to Spatial Data Organization) 
o Field names, aliases, and types 
o Metadata date stamp and scope 
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Date formats - In the Pro Metadata Editor, the date convention for ISO metadata is followed. 
Dates are YYYY-MM-DD. Times are hh:mm:ss . Most date fields are restricted in the editor to 
using the calendar date picker. If you do not know the month or day, establish a convention 
(e.g. use 2002-01-01 or 2002-12-31 if all you know is the year). When putting a date and/or 
time in a free text field, it makes sense to format it properly. When exporting to FGDC 
CSDGM xml, the contents of date/time fields will be translated to FGDC CSDGM format and 
stored that way in the xml. Contents of free text fields will remain as entered.  
 

 Error flags (little red x in left panel of Editor) - A few of these may persist, even after 
completion of all the information necessary to produce FGDC CSDGM compliant 
metadata. The Pro validator has some bugs. The Quality and Lineage sections of the 
editor are the most frequent culprits. If you are pretty sure the information is complete 
but want to check, export an FGDC CSDGM xml and run it through the MP validation 
service to identify any missing info.  
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Appendix II: Required Cataloging Elements for NJGIN  

List below is in ArcGIS Pro Metadata Editor order. This is the minimum list of elements that will 
work well for cataloging. Fields marked # are filled during ArcGIS Pro metadata synchronization 
or automatically by the Editor but can be changed. Fields marked * commonly are the same for 
many records and are candidates for template. 

Overview section 

Item Description sub-section 
o Title 
o Summary (Purpose) 
o Description (Abstract) 
o Use Limitation (Use Constraints) * 
o Bounding Box (4 coordinates) # 

Topics & Keywords sub-section 
o Topic Category (check box) 
o Content Type, and Resource Description check box 
o New Theme Keyword section, Theme Keywords (separate with comma or line break) 
o Theme Keyword Thesaurus (only if above keywords are from a published vocabulary) 
o Place Keyword 

(Resource) Citation sub-section 
o Title (same as above, edit only if necessary) 
o FGDC Geospatial Presentation Form 
o Dates -> Published (please be sure to change for each discrete data release) 

(Resource) Citation Contacts sub-section 
o Citation Contact (name and/or organization) and Role = Originator * 
o Citation Contact (name and/or organization, plus at least City and State), and 

Role = Publisher * 
 

Metadata section 

(Metadata) Details sub-section 
o Date Stamp # 

(Metadata) Contacts sub-section 
o Metadata Contact (name and/or organization) plus full contact information including 

email, and Role = Point of Contact * 
 

Resource section 

 (Resource) Details sub-section 
o Status (Progress) 

 (Resource) Extents sub-section, add a new extent sub-section 
o Temporal Instant Extent Date or Temporal Period Extent Dates (Time Period of Content 

Date(s)) 
o Temporal … Extent Description: Ground Condition, Publication Date, or free text 

(Currentness Reference) 
(Resource) Maintenance sub-section 
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o Update Frequency (Maintenance and Update Frequency) 
(Resource) Constraints sub-section 

o Legal Constraints -> Use Limitation (Distribution Liability) * 
o Legal Constraints -> Other Constraints (Access Constraints); leave out if none. * 

(Resource) Distribution sub-section -> Digital Transfer Options -> Online Resource 
o Linkage (Online Linkage) Not required for ArcGIS Online access points. Required for 

other download, service, and/or information access URLs 
 

  



 ArcGIS MD using Pro from scratch 

Page 17 of 22   19-Jan-23 

Appendix III: Required Full Metadata Elements, Editor field list 

This list includes all the fields, in Editor order, that must be filled in or edited manually in the 
ArcGIS Pro Metadata Editor (or imported from a template) to produce full metadata per 
NJDEP/NJGIN required list. Warning: the following list does not include all the fields that may 
have outdated information in them if the metadata were upgraded from an existing FGDC 
CSDGM record. 

A similar list in standard element number order is available from NJGIN: Metadata full 
documentation element checklist for typical GIS vector data for NJ, FGDC CSDGM 

Overview section 
Item Description sub-section 

o Title 
o Summary (Purpose) 
o Description (Abstract) 
o Use Limitation 

Topics & Keywords sub-section 
o Topic Category (check box) 
o Content Type, and Resource Description check box 
o Place Keyword 

(Resource) Citation sub-section 
o Title (same as above, edit only if necessary) 
o FGDC Geospatial Presentation Form 
o Dates -> Published 

(Resource) Citation Contacts sub-section 
o Citation Contact (name and/or organization) and Role = Originator 
o Citation Contact (name and/or organization, plus at least City and State), and 

Role = Publisher 
 

Metadata section 

(Metadata) Details sub-section 
o Date Stamp if not captured automatically 

(Metadata) Contacts sub-section 
o Metadata Contact (name and/or organization) plus full contact information including 

email, and Role = Point of Contact 

 
Resource section 
 (Resource) Details sub-section 

o Status 
o Supplemental Information 

(Resource) Extents sub-section 
o Temporal Instant Extent or Temporal Period Extent, including date or dates and 

Description. The latter may be Ground Condition, Publication Date, or free text. This 
information must be in a completely separate Extent entry, not together with the 
Bounding Box Extent. 
(Resource) Maintenance sub-section 

https://geoapps.nj.gov/njgin/documents/MD_Documentation_elements_FGDC_CSDGM.pdf
https://geoapps.nj.gov/njgin/documents/MD_Documentation_elements_FGDC_CSDGM.pdf
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o Update Frequency 
(Resource) Constraints sub-section 

o Legal Constraints -> Use Limitation (Distribution Liability) 
o Legal Constraints -> Other Constraints (Access Constraints); leave out if none. 

(Data) Quality sub-section 
o Report Type -> Conceptual Consistency AND  Measure -> Description [Logical 

Consistency Report] 
o Report Type -> Completeness Omission AND Measure -> Description [Completeness 

Report] 
o Report Type -> Quantitative Attribute Accuracy AND Measure -> Description [Attribute 

Accuracy Report] 
o Report Type -> Absolute External Positional Accuracy AND Dimension -> horizontal  AND 

Measure -> Description [Horizontal Positional Accuracy Report] 
o A second set of Absolute External Positional Accuracy report elements if Vertical 

Accuracy is pertinent. 
(Resource) Lineage sub-section 

o If published or archived source data or documents were used, for each one: 
 Source Description 
 Scale Denominator (only for paper maps, or data of known nominal scale) 
 Source Citation Title 
 Alternate Title [Source Citation Abbreviation] e.g. file name 
 FGDC Geospatial Data Presentation Form 
 Date Published for the Source 
 Edition (only if referenced by source documentation) 
 Source Citation Contact name and/or organization and Role =  Originator 
 Source Citation Contact name and/or organization, City, State, and 

Role = Publisher 
 Source Temporal Instant Extent or Temporal Period Extent, including date or 

dates and Description.  
o If detailed processing information is available, for each process step: 

 Process Description (include description of source(s) if not documented above) 
 Process Step Date (and time if relevant) 

 (Resource) Distribution sub-section 
Distributor sub-sub-section (Be careful to choose this correctly – it is the second 
one of three.) 

 Distributor Contact organization and/or name, Role = Distributor, and full 
contact information 

 Ordering Process Fees 
 Ordering Process Currency 
 Ordering Instructions (if special instructions are needed, or to explain secondary 

access) 
 Distribution Format -> Format Name 
 Distribution Format -> Format Version 
 Distribution Format -> Format Specification  URL to format spec   
 Distribution Format -> Decompression Technique (only if applicable) 
 Distribution Format -> Information Content (explanation of service type or file 

type in words.) 
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 Digital Transfer Options -> Units of size = M (megabytes are required) if 
applicable 

 Digital Transfer Options -> Transfer Size if applicable 
 Digital Transfer Options -> Online Resource -> Linkage direct access URL for 

service consumption or download 
Digital Transfer Options sub-sub-section (Be careful to choose this correctly – it 
is the third one of three.) 

 Online Resource -> Linkage URL for informational Web page, organization main 
Web page, etc. 

 Online Resource -> Name Descriptive name of resource 
 Online Resource -> Function  from list, or Empty 
 Add New Online Resource elements for additional URLs 

 (Resource) Fields sub-section – Entity and Attribute Information -> Details 
o Label (change the synchronized default to something more descriptive of the Entity) 
o Entity Type -> Definition 
o Entity Type -> Definition Source 
o For each field (Attribute): 

 Label 
 Definition  
 Definition Source 
 ONE of  Range Domain -> Minimum AND -> Maximum  

    Codeset Domain -> Name AND -> Source 

    Unrepresentable Domain   

OR 

One or more Enumerated Domain, including for each  

-> Value, ->Definition, ->Definition Source 
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Appendix IV: Pick lists for NJGIN 

A. ISO 19115 Topic Category codes1: For all metadata records, include one of the 
following ISO Topic Category codes (text), which expresses the Primary Theme of the data 
set, map, service, or application. In the ArcGIS Pro Metadata Editor, this entry is a check 
box; necessary entries  in the xml are made automatically by the Editor and exporter. 
Numeric (three-digit numbers as text) codes are provided for reference only. 

 
The following list describes the intended use for each keyword. 

 
o biota   002    for naturally-occurring flora and fauna, such as wildlife, biological 

sciences, ecology, wilderness, sea life, wetlands, habitats 
 

o boundaries   003     for administrative and political boundaries, i.e. legal land 
descriptions 

 
o climatologyMeteorologyAtmosphere   004     for atmospheric processes and 

phenomena, such as cloud cover, weather, atmospheric conditions, climate change, 
precipitation 

 
o economy   005     for economic activities or employment, such as labor, revenue, 

commerce, industry, tourism, ecotourism, forestry, fisheries, commercial or subsistence 
hunting, exploration and exploitation of  minerals, oil, gas 

 
o elevation   006     for height above or below sea level, such as altitude, bathymetry, 

digital elevation models, slope, and products derived from the preceding 
 

o environment   007     for environmental resources, protection, and conservation, such 
as pollution, waste storage and treatment, environmental impact assessment, 
environmental risk, and nature reserves 

 
o farming   001     for agriculture and farming, including the rearing of animals or 

cultivation of plants. For example, irrigation, aquaculture, herding, pests and diseases 
affecting crops and livestock 

 
o geoscientificInformation   008     for geological, geophysical, and other earth science 

information, such as minerals, rock structure, rock composition, rock origin, 
earthquakes, volcanic activity, landslides, gravity, soils, permafrost, hydrogeology, 
erosion 

 
o health   009     for human health and disease, health services, human ecology, and 

safety, such as human disease, human illness, factors affecting health, hygiene, mental 
and physical health, substance abuse 

 
o imageryBaseMapsEarthCover   010     for base maps, such as land cover, topographic 

maps, classified and unclassified images. 
 

o intelligenceMilitary   011      for military bases, structures, and activities, such as 
barracks, training grounds, military transportation, military information collection 

 
1 Derived from ISO Draft International Standard: Geographic information -- Metadata (ISO/DIS 19115), 
2001, Section B.5.27 MD_TopicCategoryCode<<CodeList>> (pp. 85-86); Creating and Using Metadata 
Services, 2002, ESRI, Chapter 4 – Publishing metadata in ArcCatalog. Numeric domain codes are from 
https://geo-ide.noaa.gov/wiki/index.php?title=ISO_Topic_Categories. 
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o inlandWaters   012      for inland water features and drainage systems, such as rivers, 

glaciers, salt lakes, water use plans, dams, currents, floods, water quality, hydrographic 
charts 

 
o location    013     for positional information and services, such as addresses, geodetic 

networks, postal zones and services, control points, place names 
 

o oceans   014     for features and characteristics of salt water bodies excluding inland 
waters, such as tides, tidal waves, coastal information, reefs 

 
o planningCadastre   015     for land use, such as zoning maps, cadastral surveys, land 

ownership 
 

o society   016     for characteristics of societies and cultures, such as natural 
settlements, anthropology, archaeology, education, traditional beliefs, manners and 
customs, demographic data, crime and justice, recreational areas and activities, social 
impact assessments, census information 

 
o structure   017     for man-made construction, such as buildings, museums, churches, 

factories, housing, monuments, and towers 
 

o transportation   018     for transportation networks, the means and aids for conveying 
people and goods, such as roads, airports, airstrips, shipping routes, tunnels, nautical 
charts, vehicle or vessel location, aeronautical charts, railways 

 
o utilitiesCommunication   019     for energy, water, and waste systems, and 

communications infrastructure and services, such as hydroelectricity, geothermal, solar, 
and nuclear sources of energy, water purification and distribution, sewage collection 
and disposal, electricity and gas distribution, data communication, telecommunication, 
radio, and communication networks. 
 
The following two are not in the Editor Topic Categories but can be added as keywords. 
 

o extraTerrestrial        for region more than 100 km above the surface of the Earth 
 
o disaster       for information related to disasters. Examples: site of the disaster, 

evacuation zone, disaster-prevention facility, disaster relief activities. 
 

B. Content Type codes  
Use one of the following entries. In the ArcGIS Pro  Metadata Editor, this is a drop-down 
pick list. 
o Live Data and Maps 
o Downloadable Data 
o Offline Data 
o Static Map Images 
o Other Documents 
o Applications 
o Geographic Services 
o Clearinghouses 
o Geographic Activities 
o Map Files 
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C. Tags for Federal Project Open Data (POD) (enter in Theme Keywords) 
o public   data are available or could be made available to the public 
o restricted public  available under certain use restrictions 
o non-public   data not available to the public 

 

Appendix V: Optional Tools  

Authors may find it useful to obtain content guidance documents for FGDC metadata, such as 
the Metadata Quick Guide and the FGDC Content Standard for Digital Geospatial Metadata 
Workbook. 

The tools below are useful if for editing an xml file directly, outside of a structured metadata 
editor. Not all metadata writers need to do this. 

-Notepad++, including the XML Tools plugin. This is free software under the GNU General Public 
License as published by the Free Software Foundation. The Compare plug-in also is useful. 

-XML Notepad. This is a free download form Lovett Software. Set it to save files WITHOUT initial 
Byte Order Mark. 

 

Questions may be directed to: 

NJGIN administrator  njgin@oit.nj.gov  

 

Change History 

Version 1.0  Completed  January 2023 

 

 

mailto:njgin@oit.nj.gov
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