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Transitioning from FGDC to ArcGIS metadata, FGDC style for 

ArcGIS Online 

Version 2.6 

 
This document is intended to provide guidance for data and metadata providers to the State 

of New Jersey ArcGIS Online / Open Data site, and partners whose sites are linked. The 

directions assume that the data set in question already has FGDC CSDGM metadata. There is 

a separate document for writers who are starting from scratch. 

 
https://njgin.state.nj.us/oit/gis/NJ_NJGINExplorer/docs/MD_Transitioning_FGDC_to_ArcGIS_AGO.pdf 
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Summary 

 
 Set up tools: Configure ArcCatalog 
 

 Prepare/back up existing metadata info: Archive xml 
 

 Upgrade 
 

 Fix content problems: re-order process steps, update changed info, other 
 

 File clean-up 
 

 Thumbnail, easy or custom 
 

 File for AGOL 

 
 Optional: Prepare, export, and check updated compliant FGDC CSDGM xml 

metadata file 

https://njgin.state.nj.us/oit/gis/NJ_NJGINExplorer/docs/MD_Transitioning_FGDC_to_ArcGIS_AGO.pdf
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Things to remember 

 
 If NOT starting with existing FGDC CSDGM metadata, instead of this document, 

please refer to ArcGIS Metadata for ArcGIS Online, FGDC Style, from Scratch. There 

are several important differences in workflow. Do not just start editing an existing 

FGDC CSDGM metadata record with the ArcCatalog metadata editor. This is not a 

shortcut – it makes more work, and may cause the record to become un-editable 

or even unusable. 

 

 Date formatting: for a date in a free text field, enter in this format; 
 

2018-02-15. 
 

 Change Publication Date for re-release of updated data. 
 

 Need to transfer metadata with no changes? Use the ArcToolbox Metadata 

Importer tool (Conversion tools -> Metadata -> Metadata Importer). Do not use the 

Export or Import buttons on the Description tab, nor the Export Metadata model. 

When using the tool, the Source is the file with good metadata. The Target 

metadata will be replaced in full. 

 
 
 
 
 
 
 
 
 
 

 
 For submissions of metadata to ArcGIS Online, a cleaned-up record is 

important. See Section G, Clean-up of ArcGIS Metadata. 

 
Step by Step Instructions 

 
A. Essential tools - set up in preparation 

 
1. These instructions are written for ArcGIS 10.3.1 for Desktop. In previous 

versions the ArcGIS editor does not work as well. There are no major changes to 

metadata editing in ArcGIS 10.5.1 

 
2. Remember that whatever object is highlighted in the Catalog Tree will be what 

you see in Contents and Preview. Its metadata will be visible in Description tab, 

and will be edited if you click the Edit button. 
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3. Set up ArcCatalog properly for FGDC style metadata. Customize menu -> Options 

-> Metadata tab. Set up as shown, including unchecking automatic updates, and 

prompts: (see below) 

 

 

 
 

4. Optional: Install Notepad++, including the XML Tools plugin. This is free 

software under the GNU General Public License as published by the Free Software 

Foundation. 

 
5. Optional: Install XML Notepad. This is a free download from Lovett Software. 

Set it to save files WITHOUT initial Byte Order Mark. (View -> Options -> 

Formatting Options -> No byte order mark on save = True) 

 
The above two tools are useful for editing an xml file directly, outside of a 

structured metadata editor. Not all metadata writers need to do this. 

 
6. Obtain tools that help when editing FGDC metadata, such as the Metadata Quick 

Guide and perhaps the FGDC CSDGM Workbook. 

 
7. ArcGIS Desktop Help for using the new editor to produce FGDC metadata: 

There are various useful help topics under Geodata > Data types > Metadata. The 

one you are most likely to need repeatedly is Illustrated guide to complete FGDC 

metadata, under Editing metadata > Metadata workflows. You might want to 

“Favorite” that one. 
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B. Metadata preparation steps 

 
1. Examine existing metadata in the ArcCatalog Description tab. If ArcCatalog  has 

been configured correctly as above, there will be some descriptive information at 

the top of the page (in ArcGIS format), and the full FGDC metadata at the bottom, 

in a grey font. You may have to expand the header FGDC Metadata (read-only). 

 
2. Make an archive copy of the existing metadata. Create a blank xml in an archive 

folder, using ArcCatalog context menu (rt-cl -> New -> XML Document). 

 
Use the Metadata Importer tool to copy the existing metadata info into this xml 

with NO changes. The source is the working feature class or shapefile. The target 

is the new blank xml. (See below) 
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3. Note Process Step order and dates. In order to prevent destructive scrambling of 

the order of the process steps, they must all have unique dates, or dates and 

times, in chronological order. Take a look at the existing metadata on the 

Description tab, scrolling all the way down to the bottom to the FGDC Metadata 

part of the stylesheet (be sure to expand it.) If the process steps don’t have unique 

dates/times, make notes of which process step(s) need edits for what date and/or 

time. After the upgrade, edit the missing dates or times in the ArcGIS editor, and 

the ArcGIS editor will then properly re-order the process steps. 

 

 

C. Perform the upgrade. This will draw information from the FGDC metadata and put 

it in ArcGIS format xml (different elements and organization.) 
 

1. Highlight the correct object in the Catalog Tree 

2. Click the Upgrade button on the Description tab if it is visible. 

 
 
 
 
 
 
 
 

Same function is available as an Upgrade Metadata model in the Toolbox, which 

can be used if the button is not visible. 

 
3. Set Upgrade Type to FGDC_TO_ARCGIS. 

4. Will take about half a minute. 

5. During the upgrade process, some information is synchronized with the data. 

6. 6.   WARNING; from this point on DO NOT use the old FGDC metadata editor on 

this record again. 

 

 

D. Examine the upgrade. Click on the Contents tab and then back on 

Description tab to force the Description to re-load. There now should be 

more information showing the top of the Description tab, including the correct Title. 

The Upgrade button should be missing, and some new buttons present. NOTE if you 

look at the Process Steps now, they will not be in order. 

 

 

E. Fix the Process Step order. Open the metadata for editing by clicking the Edit 

button at the top of the Description tab: 

 
 
 
 
 
 
 

Edit any dates and/or times as required (refer back to your notes and/or the old 

archived FGDC metadata to review the correct order.) Save (and close). Re-open 

editor, save-close again. The Process Steps should now be in order. (Don’t forget to 

refresh the Description, as above.) 
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F. Editing in ArcCatalog. Now edit any outdated information in the metadata, and 

also find and fix anything that is missing or did not upgrade properly. Most of the 

manual entry elements required for cataloging are listed below. Summary lists of 

elements required for cataloging and for full documentation are published by NJGIN, 

and are in Appendices to this document. If starting with more-complete metadata, be 

sure to check all existing fields for needed updates. Also look for items marked with a 

red x in the section list on the left side of the tab. Not all of these need to be fixed 

completely, but they are a place to start. (See below) 

 
IMPORTANT: Be careful which red x you click on! 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
These indicate missing 

information. 
 
 
 
 

Clicking on these will delete 

the info! BE CAREFUL!! 
 

 
 
 
 
 
 
 

To cancel bad edits, Exit without saving to revert to the way the metadata were the 

last time they were saved. For additional field guidance, hover the cursor over the 

field and look in the help bar at the bottom of the Description pane. 

 
1. Title: This should be a succinct but informative entry that will give the reader a 

good clue to the contents of the data set. Do not leave it as just the filename of 

the data set (which is what ArcCatalog may capture automatically,) although you 

may want to include a well-known filename near the end of the Title. 

2. Abstract (editor Description): A paragraph or two conveying the “what” of the 

data set. Should be intelligible to the non-specialist reader. 
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3. Purpose (editor Summary): The “why” of the data set, i.e. the business reason 

for its creation. 

4. Bounding Coordinates (Bounding Box): If the metadata are associated with the 

relevant data, should be filled in automatically by ArcCatalog during upgrade. If 

not, must be filled in manually in Item Description section, using geographic 

coordinates in signed decimal degrees. Be sure to check the box for Extent 

Contains the Resource. 

5. Topic Categories: pick one. Do NOT use Boundaries unless the data set is a 

administrative or political boundaries, such as municipal boundaries or voting 

districts. See code descriptions in Appendix V. 

6. Content Type: Pick from the list and check the box for Export as Resource 

Description. This is required for proper function in old NJGIN2 catalog, optional 

but useful in ArcGIS Online. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

7. Theme Keyword(s): Add a Theme Keywords section, then enter subject words or 

phrases that a user might choose when searching for this data item. Separate 

them with newlines. If keywords are from a published vocabulary, add a 

Thesaurus Citation in the same section. Otherwise, skip it. If the pre-upgrade 

metadata had keywords sections, some cleanup may be needed. 

8. Place Keyword(s): The most important / relevant one needs to be first in the list. 

For statewide data, should be “New Jersey”. For county data, the county name and 

state, e.g. “Sussex County, New Jersey”. 

9. Tags:  Copy all keywords into the Tags field (in Item Description sub-section) 

10. FGDC Geospatial Presentation Form: Pick from list, and/or consolidate if in a 

separate section from Presentation Form. 

11. Publication date and edition: Please be sure the publication date reflects the 

latest release of the data, not the original release. Publication date is the ONLY 

date that can be counted on to persist through crosswalks to other metadata 

formats. Please be sure to change this date every time metadata are updated for a 

discrete re-release. This becomes more and more important as the data world 

becomes more interconnected. It is optional to put any brief information about 

previous releases in edition, which is a free text field. Sample language: “Third 

edition; original publication date 2009-01-15.” More-involved histories can go in 

Supplemental Information or Process Steps. Use of Created and Revised dates is 

optional, they will persist when metadata are shared with ArcGIS products but 

will not translate into exported FGDC CSDGM standard metadata. 

12. Citation Contact Information for Originator: fill in fully-described organization, 
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and person’s name if applicable. This should be the organization and/or person 

who defined the requirements for the data set. There is no harm in completing all 

the contact information create a re-usable contact. 

13. Citation Contact Information for Publisher: fill in City and State at least. There 

is no harm in completing all the contact information to create a re-usable contact. 

14. Metadata Date Stamp: initially fills in automatically, but can be changed. 

15. Metadata Contact Information: fill in a name, full organization, and full contact 

information either for the metadata author, or for someone who will continue to 

be able to answer questions about the metadata. 

16. (Resource) Credits: Copy in Originator and Publisher, then add anyone else who 

should receive credit/thanks (partners, funding sources, etc.) 

17. Status/Progress of data set development: under Resource Details, pick the 

appropriate choice. 

18. Time Period of Content date(s): in the ArcGIS Editor, create a new Extent section, 

SEPARATE from the Extent section for bounding coordinates. To the new section, 

add Temporal Period Extent or Temporal Instant Extent and fill in date(s). If 

you can establish when the data matched the real world, Description of the Extent 

is Ground Condition. Otherwise, use Publication Date or a custom entry. 

19. Maintenance [and] Update Frequency: pick the appropriate choice. Unless there 

is a process in place for formal change detection, editing, and publishing, “as 

needed” probably is not appropriate. 

20. Access Constraints, Use Constraints, Distribution Liability: can be left out, but 

it is better to include them. Standardized language across an organization is 

appropriate in many cases, so these are good to put in a template. In the ArcGIS 

Editor, these are in the following locations: 

a) Access Constraints Resource -> Constraints -> Legal Constraints -> Other 

Constraints 

b) Use Constraints Resource -> Constraints -> General Constraints -> Use 

Limitation AND/OR Overview -> Item Description -> Use Limitation 

c) Distribution Liability Resource -> Constraints -> Legal Constraints -> Use 

Limitation 

Help with sample language as used by NJOIT – OGIS is available, see below. 

21. Security constraints for data or metadata won’t translate properly in most  

cases. The information can be omitted for public data, or use Classification 

Unclassified and change the classification system to ArcGIS. Optional: create a 

new section of Theme Keywords and enter keyword for Project Open Data 

distribution policy, one of the following as appropriate: public; restricted public; 

or non-public. These are intended to reflect various types of sensitivity, not just 

security classification. 

22. Data Quality: If this section is used, the minimum required is one Process Step 

(filled out under Lineage in the editor,) as well as a Logical Consistency Report 

(called Conceptual Consistency in the ArcGIS Editor) and a Completeness Report. 

For each report, fill in the Report Type, and a Measure -> Description if missing. 

“Complete” metadata should also contain Attribute Accuracy Report and 

Horizontal Positional Accuracy Report. The upgrade process may have generated 

several incomplete reports that will need to be edited or deleted. After doing 
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this, the Quality section may still have a little red x showing errors. However, if 

exported the FGDC CSDGM metadata xml will pass validation. 

23. Distribution Information: In AGOL and Open Data, the provider is displayed with 

the Item, from the Esri account information. Skip this section if the metadata 

won’t be used elsewhere. However, if the metadata will be used elsewhere, for 

Distribution Information to travel with the data, it will need to be filled in. If help 

is needed, see ArcGIS Desktop Help topic Illustrated guide to complete FGDC 

metadata, and jump to the Distribution Information section, to see how to fill out 

the missing parts, and/or consult the complete element list in the Appendix. It is 

a bit confusing because the ArcGIS editor is formatted to allow editors to fill this 

in for FGDC AND ISO metadata export, and they require two different 

organization schemes. For FGDC, almost all the info needs to be filled out WITHIN 

the Distributor entry. However, URLs go in two places: 

 

 
Distribution -> Distributor -> Digital Transfer Options -> Online Resource -> 

Linkage 

 
Distribution -> Digital Transfer Options -> Online Resource -> Linkage. 

 

 
Use the second one above for a direct download URL, if available and/or a 

general information URL (element is repeatable.) This one ends up in Section 1 – 

Identification Information of exported FGDC CSDGM metadata. If the metadata are 

on the old NJGIN2 catalog, the first entry also will be provided as a direct linkage 

attached to the metadata Title when it is returned from a search. If the ArcGIS 

metadata are uploaded to ArcGIS Online, an entry will be filled in automatically: 

however, in most cases this will not travel with the data set, 

 
Use the first one above for all kinds of direct access. This one ends up in Section 6 

– Distribution Information of exported FGDC CSDGM metadata. This element is 

used by other GIS data catalogs. 

 

For downloadable data, the same URL will be in two places. If confused, call 

human help listed below. 

 

24. Entity and Attribute Information: This is filled out in the Fields section. The 

upgrade may scramble the order. Fill out any missing info, and delete any 

irrelevant entries. See full metadata list below for additional help. It is not 

necessary to unscramble the order.  

 
25. Mandated creators, including NJ State vendors: are required to provide more 

information than just the essential elements for cataloging. There are separate 

help documents to assist with creating fuller metadata. 

 

 
a) A full list of elements for compliant metadata is published by NJGIN 

in several formats. 
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b) Appendix III lists the full documentation checklist elements that 

require manual entry in the ArcGIS editor. This is a shorter list 

because some of the required elements are filled in during metadata 

synchronization with the data. 

c) Help with Fields (Entity and Attribute Information) is available from 

Metadata Attribute Domain Element details – FGDC CSDGM in ArcGIS Editor 

10.3.1., which is published by NJGIN. If there already is a detailed data 

dictionary in tabular format, there are alternative ways of satisfying the 

requirements for the Fields section. Contact the human help listed below 

for more information. 

d) Help with sample language for Constraints and Distribution Liability 

is available from NJGIN. 

 

 

G. Clean-up of ArcGIS metadata. At this point the upgraded and edited metadata 

record contains both FGDC and ArcGIS elements. For a “clean” ArcGIS record of minimal 

size, with only the current, updated information in it, it will need to be cleaned up, 

removing old, un-updated FGDC elements. For publication of data and metadata to 

ArcGIS Online, this is important. 

 
1. Locate the required xslt file in the ArcCatalog install. On my Windows 7 PC, this 

file is located here: C:\Program Files 

(x86)\ArcGIS\Desktop10.3\Metadata\Stylesheets\gpTools\remove pre94 metadata 

elements.xslt. Add an ArcCatalog Tree connection to the enclosing folder for easy 

access. 

2. Start the XSLT Transformation Tool (Conversion Tools -> Metadata) and fill in as 

appropriate. The Source Metadata is the metadata you have been editing. The 

Input XSLT is shown above. The output file will be a standalone xml of partially- 

clean metadata. 

 
3. The resulting output file will have no FGDC CSDGM elements in it except for the 

ones that are re-used by ArcGIS metadata. However, it will still have a binary 

enclosure of the pre-upgrade metadata (FGDC CSDGM if that is what you started 

with.) 

4. Delete FGDC enclosure. When FGDC metadata are upgraded to ArcGIS metadata, 

the original FGDC content also is compressed and stored within the xml as a 

binary enclosure. This is distinct from the FGDC xml elements still in xml 

format, which were deleted above. Removing this old content will make the 

resulting file quite a bit smaller. 
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a) Highlight the metadata file in the ArcCatalog tree. 

b) Click the Metadata Properties button 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

c) Select the source_metadata.xml enclosure. Make sure there is an archived 

copy of the original metadata, or click Save As, and put the xml in an archive 

location. Then click Delete and then Apply. Click OK to dismiss the dialog. 

5. Check the cleaned-up, stand-alone file in ArcCatalog to make sure all the desired 

content is there and the FGDC Metadata part of the Description stylesheet shows 

only Entity and Attribute Information. 

6. Transfer the cleaned-up metadata content back to the data set by using the 

Metadata Importer tool. 

 

H. Create thumbnail 

 
1. Automatic via ArcCatalog (easy): select the data set in the Catalog Tree. Switch 

to the Preview tab in the Contents pane and click the thumbnail button on the 

 
 

Geography toolbar. 
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2. A branded, custom thumbnail is strongly recommended for vetted data to be 

registered in ArcGIS Online. Human help listed below can provide further 

information. 

3. Custom: Create a customized view of the data in ArcMap, and a custom image. 

a) Set the layout Data Frame Properties to Size width = 2.08in, height = 1.38in. 

This will yield a 200 x 133 pixel image at resolution of 96 dpi. 

b) Add a base map or layer. Symbolize data and zoom to a pleasing scale. Check 

in layout view. Add a branding banner image if desired. 

c) Choose File -> Export Map, with options as follows: 

d) Save as type JPEG 

e) Resolution 96 dpi 

f) Clip output to graphics extent ON 

g) Once the JPEG file has been created, switch to ArcCatalog, select the data set, 

and start the ArcGIS metadata editor. Import the image by using the Update 

button under the thumbnail or placeholder. If further info is needed, see 

ArcGIS Help instructions Creating a thumbnail from the Description tab. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
I. Preparing metadata for ArcGIS Online: ArcGIS Online metadata upload 

capability accepts only ArcGIS metadata xml without any extraneous elements. If you 

have not cleaned out old FGDC CSDGM material, go back to G. 

 
1. Incorporate a custom thumbnail, or create an automatic thumbnail using 

ArcCatalog (instructions for both above.) 

2. Consider adding keywords/tags: any keywords put in keyword fields and 

copied into Tags in the metadata will be written into the AGOL Item Tags, the first 

time you load a metadata file. If you update existing metadata on AGOL, any 

additional keywords may have to be added to the Item Tags manually. 

3. Consider copying Originator and Publisher into Credits: This will enable them 

to show up in the AGOL Item front page. 

4. Consider cleaning out “private” information: several classes of information can 

be removed from the metadata record using the XSLT Transform tool, described 

in step G above. Automatically-collected geoprocessing information can be 

removed by using the tool with remove geoprocessing history.xslt; references to 

computing platform addresses can be removed by using the tool with remove 

local storage info.xslt. Note that each time the tool is run, the Source 
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Metadata is the previous metadata, and the Output File is a new metadata xml 

file of the processed output metadata. To propagate these changes to the data-

attached metadata, import the final xml into association with the data, using the 

Metadata Importer tool (see Things to remember, above.) 

5. If the AGOL Item will not be created by uploading a shapefile, create a 

standalone ArcGIS xml: 

a) Invoke the XSLT Transform tool. Use exact copy of.xslt for the Input. The 

Source will be either the metadata on your data, or a more cleaned-up xml 

file produced above. 

b) Name the output to make it recognizable as ArcGIS metadata for the correct 

data set (e.g. Govt_admin_county_seat_3857_Arc.xml) 

6. Sign into AGOL and upload the xml file. If the Item is created by uploading a 

zipped shapefile with metadata, skip this step. On the AGOL Content item interface, 

a standalone xml file can be uploaded using the Metadata (-> Edit) button. When 

the editor interface comes up, click the Open or Overwrite  button, which will 

allow browsing to the standalone file, and then upload the file. Then Save and 

Close. Then check the Item page to confirm changes 

 

J. Producing FGDC CSDGM metadata (Optional – required for vendor deliveries 

to NJ State Agencies): 

1. In ArcCatalog, highlight the data set with completed ArcGIS metadata, in the 

Catalog Tree. 

2. Double check a few crucial items 

a) Topic Category chosen 

b) Content Type chosen correctly 

c) All elements/fields in required list have been added or updated (see 

Appendix.) 

d) Save if Editor is open. 

3. Produce the FGDC CSDGM xml file by using the Export button on the 

Description tab. 

 
 
 
 
 
 
 
 
 

(Another option is the toolbox Export Metadata MODEL) 
 

 
a) Source Metadata is the working data set. 

b) Translator is ARCGIS2FGDC.xml. Will be filled in automatically if the 

metadata style is set up correctly and you use the button. 

c) Direct the output file to a convenient location. Give the xml file a name with 

FGDC in it. 

 

4. Check the FGDC CSDGM xml to make sure any updated content is in it. To do this, 

look at the FGDC CSDGM xml in ArcCatalog, Description tab, in the gray bottom 

section FGDC Metadata (read-only). The complete list in CSDGM order is available 

from NJGIN, at 
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https://njgin.state.nj.us/oit/gis/NJ_NJGINExplorer/docs/MD_Documentation_eleme

nts_FGDC_CSDGM.pdf.  

 

5. Fix missing or incorrect elements in the ArcGIS metadata for the data set, not in 

the exported FGDC CSDGM format xml. To find the right place in the editor to 

put in the info, see 8.d) below. 

6. When done, re-export FGDC CSDGM xml. 

7. Repeat steps 3 – 6 until the FGDC CSDGM xml is complete. Don’t edit or move the 

completed FGDC CSDGM xml with the ArcGIS Metadata Editor. Viewing it on the 

Description tab is ok. 

8. Validate FGDC CSDGM xml with USGS MP validation service. Steps c-e) are 

optional unless a complete, compliant record is required for your workflow. 

 
a) In a web browser, open the Geospatial Metadata Validation Service at 

https://geo-nsdi.er.usgs.gov/validation/ . This service is based on Metadata 

Parser by Peter Schweitzer of the USGS. 

b) Browse for the FGDC CSDGM xml metadata file, check on the Upgrade and 

Indent XML options, and Validate. 

c) Open the error report. If there are errors that should be fixed, note what the 

element names and numbers are and the line numbers. 

d) Find out where to look in the ArcGIS editor for the corresponding fields. You 

may need to use some combination of the Checklist spreadsheet, the FGDC 

CSDGM Workbook, the ArcCatalog Illustrated Guide to complete FGDC 

metadata, and the FGDC CSDGM xml opened in Notepad++. Searching the 

latter by line number is useful if the error involves a repeating element and 

you need to figure out which instance is causing the problem. Dan or Edith 

will be happy to help if you get stuck. 

e) Go back to ArcCatalog, highlight the working data set, and invoke the 

ArcCatalog metadata editor. Work with the metadata in the data set. The 

idea is to edit the source metadata on the data set, then re-export, etc. 

Repeat steps for editing, exporting, and validating, until you are satisfied 

with your product. 

f) Run the final exported FGDC CSDGM xml through the USGS MP validation 

service. Save the output ZIP, and extract the output FGDC CSDGM xml. Use 

this xml for any use where standard compliance is important. It is formatted 

with an initial declaration line (<?xml version="1.0" encoding="UTF-8"?>) and 

without an initial Byte Order Mark (BOM). It also has attribute domain 

information re-formatted to be standard-compliant (ArcGIS formats these 

elements incorrectly.) Move this file only with Windows, not with 

ArcCatalog. 

https://geo-nsdi.er.usgs.gov/validation/
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Appendix I: A few nifty features and quirks of the ArcGIS Editor 

 
 Contact Information – The ArcGIS editor includes a Contacts Manager, which can save 

Contact Information packages to a file on the PC or server where ARcGIS is installed. The 

contacts can then be re-used. When a metadata record is open in the Editor, the Contacts 

Manager (section) lists all the Contacts saved in the Manager file (first,) and then all the 

additional ones in the current metadata record. You can save new ones or un-save old 

ones in this view. Un-checking will not delete the entry from the current metadata, just 

from the saved ones. When you load a saved contact somewhere in the ArcGIS editor, 

don’t forget to change the role for the new instance of use. If you are comfortable editing 

xml files in an xml editor, you can edit directly the file where the saved contacts are 

stored:  at ArcGIS 10.3.1, this file is located here: 

<user documents>/ArcGIS/Descriptions/contacts.xml . 

 
 Synchronization – we are done struggling with manually entering Spatial Reference 

information. As long as there is a proper spatial reference on the data, ArcGIS will read it 

into the metadata. Quite a bit of other information also gets read in this way, depending 

on how the synchronization is invoked. The full list of what can get synchronized for a 

feature class is below: 

 
o Title – gets file or feature class name 

o Bounding Coordinates in decimal degrees 

o Content Type as Downloadable Data 

o Presentation Format e.g. digital map 

o Dataset language as English (United States) 

o Spatial representation as vector (if it is polygons) 

o Processing environment (Windows build version etc) 

o ArcGIS Item properties, including file location (these are non-editable, but don’t get 

exported in the FGDC xml) 

o Extents, both geographic coordinates and native coordinate system units 

o Spatial Reference, both EPSG reference and full instantiated elements 

o Spatial Data Properties (roughly equivalent to Spatial Data Organization) 

o Field names, aliases, and types 

o Metadata date stamps and scope 

 
 Synchronization options – some operations perform a set type of synchronization. If 

you synchronize manually, you can control what gets synchronized to some extent: 

o ALWAYS – Does not change an edited Title, but will fill it in if blank. 

o ACCESSED – Elements will be synchronized whenever an ArcGIS client accesses the 

data, even if ArcCatalog is set to not do this. The sync will reset some date stamps, for 

example, every time someone examines the data. Once ACCESSED is chosen, it is set 

for the data object and is difficult to change. 

o CREATED – If metadata are present but empty, does not fill elements. 

o NOT_CREATED – Will fill above elements if empty, and update some even if filled. 

Does not over-write edited Title or a manually-entered bounding box. 

o OVERWRITE – Overwrites all of the above, even if they have been edited by a human 

already (Existing readable Title gets destroyed.) However, existing attribute definitions 

are not destroyed. 

o SELECTIVE – Overwrites the above with info from current data, except for Title and 

Content Type. 
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 Date formats: In the ArcGIS editor, the date convention for ISO metadata is followed. 

Dates are YYYY-MM-DD. Times are hh:mm:ss . Most date fields are restricted in the editor 

to using the calendar date picker. If you do not know the month or day, you will have to 

establish a convention (e.g. use 2002-01-01 or 2002-12-31 if all you know is the year). 

When putting a date and/or time in a free text field, it makes sense to format it properly. 

When exporting to FGDC CSDGM xml, the  contents of date/time fields will be translated 

to FGDC CSDGM format (YYYYYMMDD) and stored that way in the output xml. Contents 

of free text fields will remain as entered. The ArcGIS stylesheets display almost all dates 

in the ISO format if the date has been properly-formatted in an FGDC xml date field. 

 
 Error flags (little red x in editor section list): A few of these may persist, even after 

completion of all the information necessary to produce FGDC CSDGM compliant 

metadata. The Quality and Lineage sections of the editor are the most frequent culprits. 

If you are pretty sure the information is complete but want to check, export an FGDC- 

CSDGM xml and run it through the MP validation service to identify any missing 

information.
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Appendix II: Required Cataloging Elements for NJGIN3 

 
List below is in ArcCatalog editor order. These are the minimum elements that will work for 

cataloging. Fields marked # are filled during ArcCatalog synchronization or automatically by 

the editor, but can be changed. Fields marked * are commonly the same for many records 

and are candidates for template. 

 
Warning: the following list does not include all the fields that may have outdated 

information in them, if metadata were upgraded from an existing FGDC CSDGM record. 

 

 Overview section 

 

Item Description sub-section 

o Title 

o Tags (come back to this after keywords and copy all of them in) 

o Summary (Purpose) 

o Description (Abstract) 

o Credits (include Originator, Publisher, anyone else to thank) 

o Use Limitation (Use Constraints) * 

o Bounding Box (4 coordinates) # 

Topics & Keywords sub-section 

o Topic Category (check box) 

o Content Type 

o Theme Keyword 

 Theme Keywords (separate with line break)   

 Theme Keyword Thesaurus (only if above keywords are from a published 

vocabulary)  

o Place Keyword(s) 

(Resource) Citation sub-section 

o Title (same as above, edit only if necessary) 

o FGDC Geospatial Presentation Form 

o Dates -> Published (please be sure to change for each discrete data release) 

(Resource) Citation Contacts sub-section 

o Citation Contact (name and/or organization) and Role = Originator * 

o Citation Contact (name and/or organization, plus at least City and State), and Role = 

Publisher * 

 
 Metadata section 

 

(Metadata) Details sub-section 

o Date Stamp # 

(Metadata) Contacts sub-section 

o Metadata Contact (name and/or organization) plus full contact information including 

email, and Role = Point of Contact * 

 

 
[more] 
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 Resource section 

 

(Resource) Details sub-section 

o Status (Progress) 

(Resource) Extents sub-section, Add a new Extent sub-section 

o Temporal Instant Extent Date or Temporal Period Extent Dates (Time Period of Content 

Date(s)) 

o Temporal … Extent Description: Ground Condition, Publication Date, or free text 

(Currentness Reference) 

(Resource) Maintenance sub-section 

o Update Frequency (Maintenance and Update Frequency) 

(Resource) Constraints sub-section 

o Legal Constraints -> Use Limitation (Distribution Liability) * 

o Legal Constraints -> Other Constraints (Access Constraints); leave out if none. * 

(Resource) Distribution sub-section -> Digital Transfer Options -> Online Resource 

o Linkage (Online Linkage) Not required for ArcGIS Online access points. Required for 

other download and/or service points. 
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Appendix III: Required Full Metadata Elements, Editor field list 

 
This list includes all the fields, in Editor order, that must be filled in or edited manually in 

the ArcCatalog Metadata Editor to produce full metadata per NJDEP/NJGIN required list. 

Warning: the following list does not include all the fields that may have outdated 

information in them, if metadata were upgraded from an existing FGDC CSDGM record. It 

also does not include fields that normally are filled in automatically by ArcCatalog 

synchronization with the data, and do not need to be changed. 

 
 Overview section 

 

Item Description sub-section 

o Title 

o Tags (come back to this after keywords and copy all of them in) 

o Summary (Purpose) 

o Description (Abstract) 

o Credits (include Originator, Publisher, anyone else to thank 

o Use Limitation (Use Constraints) 

Topics & Keywords sub-section 

o Topic Category (check box) 

o Content Type 

o Theme Keyword 

 Theme Keyword(s) separate with line break 

 Theme Keyword Thesaurus (only if above keywords are from a published 

vocabulary) 

o Place Keyword(s) 

(Resource) Citation sub-section 

o Title (same as above, edit only if necessary) 

o FGDC Geospatial Presentation Form 

o Dates -> Published (please be sure to change for each discrete data release)  

(Resource) Citation Contacts sub-section 

o Citation Contact (name and/or organization) and Role = Originator 

o Citation Contact (name and/or organization, plus at least City and State), and Role = 

Publisher 

 

 Metadata section 

 

(Metadata) Contacts sub-section 

o Metadata Contact (name and/or organization) plus full contact information including 

email, and Role = Point of Contact 

 

 Resource section 

 

(Resource) Details sub-section 

o Status 

o Supplemental Information 

(Resource) Extents sub-section 

o Temporal Instant Extent or Temporal Period Extent, including date or dates and 

Description. The latter may be Ground Condition, Publication Date, or free text. This 

information must be in a separate Extent entry, not in the same one as the Bounding 

Box Extent. 
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(Resource) Maintenance sub-section 

o Update Frequency 

(Resource) Constraints sub-section 

o Legal Constraints -> Use Limitation (Distribution Liability) 

o Legal Constraints -> Other Constraints (Access Constraints); leave out if none. 

(Data) Quality sub-section 

o Report Type -> Conceptual Consistency AND Measure -> Description [Logical 

Consistency Report] 

o Report Type -> Completeness Omission AND Measure -> Description [Completeness 

Report] 

o Report Type -> Quantitative Attribute Accuracy AND Measure -> Description [Attribute 

Accuracy Report] 

o Report Type -> Absolute External Positional Accuracy AND Dimension -> horizontal 

AND Measure -> Description [Horizontal Positional Accuracy Report] 

o A second set of Absolute External Positional Accuracy report elements if Vertical 

Accuracy is pertinent. 

(Resource) Lineage sub-section 

o If published or archived source data or documents were used, for each one, add a 

Source: 

 Source Description 

 Scale Denominator (only for paper maps, or data of known nominal scale) 

 Source Citation Title 

 Alternate Title [Source Citation Abbreviation] e.g. file name 

 FGDC Geospatial Data Presentation Form 

 Date Published for the Source 

 Edition (only if referenced by source documentation) 

 Source Citation Contact name and/or organization and Role = Originator 

 Source Citation Contact name and/or organization, City, State, and Role = Publisher 

 Source Temporal Instant Extent or Temporal Period Extent, including date or 

 dates and Description. 

o If detailed processing information is available, for each process step, add a Process 

Step: 

 Process Description 

 Process Step Date (and time if relevant) 

(Resource) Distribution sub-section 

Distributor sub-sub-section (Be careful to choose this correctly – it is the second 

one of three.) 

 Distributor Contact organization and/or name, Role = Distributor, and full 

contact information 

 Ordering Process Fees 

 Available Date or Date Period 

 Ordering Instructions 

 Distribution Format -> Format Name 

 Distribution Format -> Format Version 

 Digital Transfer Options -> Online Resource -> Linkage (direct access URL for 

download or service consumption) 

Digital Transfer Options sub-sub-section (Be careful to choose this correctly – it is 

the third one of three.) 

 Online Resource -> Linkage Repeatable element. First one should be a direct 

access URL if there is one. Add repeating elements for informational Web 

page, organization main Web page, etc. 
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(Resource) Fields sub-section – Entity and Attribute Information 

 

o Label (change the synchronized default to something more descriptive of the Entity) 

o Entity Type -> Definition 

o Entity Type -> Definition Source 

o For each field (Attribute): 

 Label 

 Definition 

 Definition Source 

 ONE of  

 Range Domain -> Minimum AND -> Maximum  

 Codeset Domain -> Name AND -> Source  

 Unrepresentable Domain 

OR 

 
 One or more Enumerated Domain, including for each 

 
-> Value, ->Definition, ->Definition Source 
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Appendix V: Pick lists for NJGIN 

 
A. ISO 19115 Topic Category codes 

1

 – For all metadata records, include one of 

the following ISO Topic Category codes (text), which expresses the Primary Theme of the 

data set, map, service, or application. In the ArcCatalog Editor, this entry is a check box; 

the keyword and the Thesaurus entries are made automatically by the editor and 

exporter. Numeric (three digit numbers as text) codes are provided for reference only. 

 
Theme Keyword Thesaurus: ISO 19115 Topic Category Theme 

Keywords: 

o biota   002   for naturally-occurring flora and fauna, such as wildlife, biological 

sciences, ecology, wilderness, sea life, wetlands, habitats 

 
o boundaries   003 for administrative and political boundaries, i.e. legal land 

descriptions; 

 
o climatologyMeteorologyAtmosphere   004   for atmospheric processes and 

phenomena, such as cloud cover, weather, atmospheric conditions, climate change, 

precipitation 

 
o economy 005   for economic activities or employment, such as labor, revenue, 

commerce, industry, tourism, ecotourism, forestry, fisheries, commercial or 

subsistence hunting, exploration and exploitation of minerals, oil, gas 

 
o elevation   006   for height above or below sea level, such as altitude, bathymetry, 

digital elevation models, slope, and products derived from the preceding 

 
o environment   007   for environmental resources, protection, and conservation, such 

as pollution, waste storage and treatment, environmental impact assessment, 

environmental risk, and nature reserves 

 
o farming   001   for agriculture and farming, including the rearing of animals or 

cultivation of plants. For example, irrigation, aquaculture, herding, pests and 

diseases affecting crops and livestock 

 
o geoscientificInformation  008  for geological, geophysical, and other earth science 

information, such as minerals, rock structure, rock composition, rock origin, 

earthquakes, volcanic activity, landslides, gravity, soils, permafrost, hydrogeology, 

erosion 

 
o health   009   for human health and disease, health services, human ecology, and 

safety, such as human disease, human illness, factors affecting health, hygiene, 

mental and physical health, substance abuse 

                                                           
1 Derived from ISO Draft International Standard: Geographic information -- Metadata (ISO/DIS 19115), 2001, Section 
B.5.27 MD_TopicCategoryCode<<CodeList>> (pp. 85-86); Creating and Using Metadata Services, 2002, ESRI, Chapter 4 
– Publishing metadata in ArcCatalog; and NOAA EDM ISO 19115 and 19115-2 CodeList Dictionaries - 
MD_TopicCategoryCode at https://geo-ide.noaa.gov/wiki/index.php?title=ISO_19115_and_19115-
2_CodeList_Dictionaries#MD_TopicCategoryCode. Numeric domain codes are from https://geo-
ide.noaa.gov/wiki/index.php?title=ISO_Topic_Categories. 
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o imageryBaseMapsEarthCover   010   for base maps, such as land cover, topographic 

maps, classified and unclassified images. 

 
o intelligenceMilitary   011   for military bases, structures, and activities, such as 

barracks, training grounds, military transportation, military information collection 

 
o inlandWaters   012  for inland water features and drainage systems, such as rivers, 

glaciers, salt lakes, water use plans, dams, currents, floods, water quality, 

hydrographic charts 

 
o location   013   for positional information and services, such as addresses, geodetic 

networks, postal zones and services, control points, place names 

 
o oceans   014   for features and characteristics of salt water bodies excluding inland 

waters, such as tides, tidal waves, coastal information, reefs 

 
o planningCadastre   015   for land use, such as zoning maps, cadastral surveys, land 

ownership 

 
o society   016   for characteristics of societies and cultures, such as natural 

settlements, anthropology, archaeology, education, traditional beliefs, manners and 

customs, demographic data, crime and justice, recreational areas and activities, 

social impact assessments, census information 

 
o structure   017   for man-made construction, such as buildings, museums, churches, 

factories, housing, monuments, and towers 

 
o transportation   018   for transportation networks, the means and aids for conveying 

people and goods, such as roads, airports, airstrips, shipping routes, tunnels, 

nautical charts, vehicle or vessel location, aeronautical charts, railways 

 
o utilitiesCommunication  019   for energy, water, and waste systems, and 

communications infrastructure and services, such as hydroelectricity, geothermal, 

solar, and nuclear sources of energy, water purification and distribution, sewage 

collection and disposal, electricity and gas distribution, data communication, 

telecommunication, radio, and communication networks. 

 

o extraterrestrial     for region more than 100 km above the surface of the Earth 

 

o disaster     for information related to disasters. Examples: site of the disaster, 

evacuation zone, disaster-prevention facility, disaster relief activies. 
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B. Content Type codes If metadata will be used in ArcIMS metadata server, use EXACTLY 

ONE of the following entries, exactly as shown, and check on Export to Resource 

Description: 

o Live Data and Maps 

o Downloadable Data 

o Offline Data 

o Static Map Images 

o Other Documents 

o Applications 

o Geographic Services 

o Clearinghouses 

o Geographic Activities 

 

C. NJ Framework data layers keywords Use one of these only if the subject applies, 

your organization is the authoritative source, and the data originate with your 

organization (not copies of data from elsewhere). Use with Keyword Thesaurus name 

NJGIN  

o njfw_geocontrol Geodetic control 

o njfw_orthophoto   Geo-referenced images of the Earth’s surface 

o njfw_boundaries   Boundaries of federal, state, local, tribal governments as 

reported/certified to the US Census Bureau 

o njfw_cadastral Geographic extent of right, title and interest in real property 

(tax parcels, zoning, easements, etc.) 

o njfw_hydro Surface water features 

o njfw_elevation Geo-referenced digital representations of vertical position 

above or below a datum surface 

o njfw_transport Geographic locations, interconnectedness, and characteristics 

of the transportation system 

 

[MORE] 
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o njfw_critical Locations of the following: 

 Emergency Operations Centers 

 Police Stations 

 Fire Stations 

 Emergency Medical Services Stations 

 Coverage Areas for the above 

 Hospitals 

 Schools 

 Colleges and Universities 

 Day Care Facilities 

 Government Buildings 

 Power Generating Plants 

 Power Substations 

 Armories 

 Military Sites 

 Communication Towers 

 Telecommunication Sites 

 Utility Transmission Lines 

 Sports Arenas / Stadiums 

 TCPA Sites 

 SARA Sites 

 Ingestion Zones 

 Prisons 

 Evacuation Routes 

 Drinking Water Intakes 

 Sewage Pumps 

o njfw_lulc Land use and land cover conditions 

 
D. Tags for Open Data (enter in Theme Keywords) 

o public data are available or could be made available to the public 

o restricted public available under certain use restrictions 

o non-public data not available to the public 

 

 
 

Questions may be directed to: 

 

Edith Konopka Edith.Konopka@tech.nj.gov 609-777-3774 

NJ Office of Information Technology, Office of Geographic Information Systems 

 

OR 

Daniel Oliva Daniel.Oliva@dep.nj.gov 609-777-4324 

NJ Department of Environmental Protection, Office of Information Resource Management, Bureau of GIS 

 

 
Change History 

 

Version 2.6 released 22 October 2018 – Edits to Element lists, use hint for Metadata Importer tool, other 

minor changes. 

 

Version 2.4 release 20 August 2018 – Removed help information for NJGIN2. Corrected some URLs. 

Additional editorial changes. 
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Version 2.2 released 15 May 2018 – Added use of XSLT Transformation tool; edits to Appendix 

information. 

 

Version 2.0 released 16 April 2018 – Extensive re-write from original Transitioning… document. 

 

 


